Input method on styled line will leak the first character into editor

Steps to reproduce

  1. Start obsidian 1.5.11 on linux
  2. Style a line to header (or checkbox and other styled line), note that level 1 header doesn’t have the problem, only 2 and above.
  3. Use fcitx5 input method to type in chinese

Did you follow the troubleshooting guide? [Y/N]

Y, I’ve tried in the sandbox and can reproduce the problem

Expected result

The input method should not have anything leaked to obsidian since those characters are just encoding the corresponding Chinese.

Actual result

The first typed-in character will be duplicated and appear after the input cursor.


Obsidian version: v1.5.11
Installer version: v1.5.11
Operating system: #1 ZEN SMP PREEMPT_DYNAMIC Sat, 16 Mar 2024 17:15:23 +0000 6.8.1-zen1-1-zen
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: light
Community theme: Minimal v7.5.2
Snippets enabled: 2
Restricted mode: off
Plugins installed: 29
Plugins enabled: 25
1: Advanced URI v1.40.0
2: Dataview v0.5.64
3: Latex Suite v1.9.1
4: Linter v1.23.2
5: Number Headings v1.16.0
6: Paste image rename v1.6.1
7: Periodic Notes v0.0.17
8: Zotero Integration v3.1.7
9: Templater v2.2.3
10: Tag Wrangler v0.6.1
11: Style Settings v1.0.8
12: Smart Typography v1.0.18
13: Shortcuts extender v2.2.0
14: Preview Mode Keybinds v0.1.2
15: Remember cursor position v1.0.8
16: QuickAdd v1.8.1
17: Kanban v1.5.3
18: Advanced Tables v0.21.0
19: Spaced Repetition v1.11.2
20: Minimal Theme Settings v7.3.1
21: BRAT v0.8.4
22: sync-to-xlog v0.2.1
23: Zoom v1.1.2
24: Omnivore v1.9.4
25: Vimrc Support v0.9.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

The above bug report has been tested reproducible on my machine on the following linux setups:

  1. Xorg
  2. Wayland
  3. Sandboxed vault
  4. With or without vim support
  5. With or without community plugin
  6. Source code mode
  7. Live preview mode

Additionally, I’ve managed to get normal behavior by reverting back to the 1.5.8 obsidian.

I think I encounter with similar issue here, when I try to input Chinese characters using fcitx, the first letter will just leak into editor, for example, when I try to input “你好”, which I should type “nihao”, when i finished input, the letter “n” just followed at the end of what I input. Problem occurs when I input in checkbox or outline. I am using Obsidian 1.5.11 on archlinux (kernel: 6.6.22-1-lts x64; KDE plasma: 6.0.2). Issue appeared after recently update obsidian.
Peek 2024-03-27 17-11

That is the same problem, both header and lists are affected by this. Also the archlinux, you can revert to the last version to avoid the problem temporarily (1.5.8). But remember you have to turn off the auto update, which is pretty tricky to disable. I suggest remove the ~/.config/obsidian directory when obsidian is down, and in the meantime disable your network, so that you get the chance to turn off the auto update before it updates automatically :slight_smile:

Duplicate of: