Importer cannot handle colon and slash in page titles for Roam Import

Steps to reproduce

Import a roam graph that contains colons ( : ) and/or slashes (/) in page titles. For page titles that contain colons or slashes, a subfolder is created instead of a note, which in turn contains a note.

Did you follow the troubleshooting guide? [Y/N]


Expected result

When importing a roam graph from a JSON file, roam pages - even if their title contains a colon or a slash - should each be imported as an Obsidian note instead of creating a folder containing a note. If the characters (colon and slash) are not compatible, they should be replaced during the import process. The import tools of Tana and Logseq, for example, do not have this problem when importing Roam graphs as JSON (but I want to use Obsidian).

Actual result

For each page in the roam graph to be imported (file format of the export: JSON) that contains a colon or a slash, an Obsidian note is not created as expected, but a subfolder whose name is the original page title up to the character, and in it a note whose title is the original page title after the character.


Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.1.0: Mon Oct 9 21:28:12 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T8103 23.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Importer v1.5.5

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I have already created the bug report on Github.
I have also taken note of this bug report, but I don’t think it describes the problem. In this case, the roam graph was exported as a folder of markdown files, which caused the error. In my case, the export is a JSON file, so the error does not occur when exporting from Roam, but when importing into Obsidian.

I hope the bug report is correct in this subforum, although it is a plugin. Otherwise, please move the topic accordingly.

Any chance of this getting fixed at some point? Would love to switch to Obsidian, but this bug in combination with the size of my roam-Graph (and the corresponding amount of wrongly imported pages) makes it impossible right now…

Importer bugs go in that plugin repo

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.