IME input not working under native Wayland

Steps to reproduce

Force the use of Wayland (e.g. set OBSIDIAN_USE_WAYLAND=1 parameter in Flatseal) and try writing CJK text with a IME like IBus-Anthy.

Expected result

After switching input method and starting to type, show the IME UI and convert characters, even under Wayland.

Actual result

It just outputs the normal key letter of my original layout with no conversion. Dictionary is also not showing up.
IME is immediately working on any other window.

Environment

  • Operating system: Linux (Fedora Workstation 37)
  • Package: Flatpak
  • Debug info:
SYSTEM INFO:
	Obsidian version: v1.1.9
	Installer version: v1.1.9
	Operating system: #1 SMP PREEMPT_DYNAMIC Mon Dec 19 17:44:54 UTC 2022 6.0.14-300.fc37.x86_64
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: off
	Live preview: off
	Legacy editor: off
	Base theme: light
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 11
	Plugins enabled: 0

Additional information

  • This broke somewhere between the v1.0 and the Canva update (discovered in v1.1.8, not fixed in latest).
  • Reverting back to stock (XWayland) fix the problem.
  • NOTE: I know that I’m forcing a non-default behavior at the moment, but given that Obsidian ships a quite up-to-date Electron version, IMHO it’s not farfetched to run it as Wayland native.

We don’t take bug reports with flatpak because we don’t produce the flatpak. try the snap or appimage.

If with chrome on wayland doesn’t work here https://codemirror.net/try/, then you should open a bug report directly to codemirror.

If it does work there and you can repro the problem with snap or appimage, open a new bug report here.

Anecdotally, we had people use fcitx5 without issues.