IME (fcitx) doesn't work when Wayland is enabled

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

Open Obsidian, switch to fcitx5 and type some CJK characters.

Things I have tried

Flatpak version and App Image version, both of which the IME works only when wayland is disabled. However, this will make the application window blurry under fractional scaling.
Similar to the issue reported here: IME input not working under native Wayland however that issue only reports on flatpak version but is also happens in the AppImage version I have tried.

Hi breakfastberry.

I am using Ubuntu 24.04 LTS x86_64(wayland) and have the same problem. But I brought the deb package from the official obsidian website and installed it with dpkg -i and it works well. I know it’s not a radical solution, but if you want to use obsidian, I hope I could help you. And I sincerely hope that this problem will be solved fundamentally.

Side note
Sorry if my English is not correct.