I just CAN NOT paste anything as plain text in Obsidian, no matter what I try

Things I have tried

What I’m trying to do

First of all: I am on an Macbook Pro

I have the text below, copied from my doctor’s website, and it is not a link on the website. Just plain text. Believe me, I am a webdesigner, I know all about that sh!t. And I just CAN NOT paste it as plain text in Obsidian, no matter what I try. This is hairpulling frustrating.

The text: “Openingstijden: Dagelijks van 8-17 uur m.u.v. vrijdag 8-12 uur” (without the “”)

  • cmd+V gives: [ ](<Openingstijden: Dagelijks van 8-17 uur m.u.v. vrijdag 8-12 uur>)

  • cmd+Shift+V gives: [ ](<Openingstijden: Dagelijks van 8-17 uur m.u.v. vrijdag 8-12 uur>)

  • cmd+alt (option)+Shift+V gives: [ ](<Openingstijden: Dagelijks van 8-17 uur m.u.v. vrijdag 8-12 uur>)

  • rightclick+Paste gives: [ ](<Openingstijden: Dagelijks van 8-17 uur m.u.v. vrijdag 8-12 uur>)

  • rightclick+Paste as plain text gives: [ ](<Openingstijden: Dagelijks van 8-17 uur m.u.v. vrijdag 8-12 uur>)

  • In settings, I have tried turning on/off the following several things, but I use Obsidian in Dutch so I can’t tell you what those settings are in English. They had to do with automatically adding “” and () and idem for Markdownsyntax. Also toggled on/off Automatically convert HTML. None of that worked.

Also, when I copy some code or text from one note to another, or even inside the same note, e.g. this:

{"name":"Default","mapZoom":15,"centerLat":51.45197420000002,"centerLng":5.466783700000013,"query":"path:\"People/Woningstichting 'thuis.md\"","chosenMapSource":0}

This happens:

{"name":"Default","mapZoom":15,"centerLat":51.45197420000002,"centerLng":5.466783700000013,"query":"path:\"People/Woningstichting 'thuis.md\"","chosenMapSource":0}

THIS IS DRIVING ME NUTS…solution or tips, anyone? Thanks very much in advance for your time/help!

Quoted with a little bit of reformatting. Please use four backticks around the entire text, when you need to insert text with triple backticks in it. It makes it a lot easier to read. Here is an example of how to write it:

... e.g. this:

mapview ...

OK, it seems like you are automatically turning everything you type into links, and I’m not sure how you managed to turn that on. What happens if you hit enter before entering text, does it still misbehave?

Are you somehow within a link, when you type? Does the same happen if you create a new note, and start typing?

If it still happens, can you open a sandbox vault, and see if the same happens there as well?

If the text is from this site, well, it works fine for me (so it’s not the text).

Sounds as though a plugin or hotkey is in conflict.

Does it work if you use the menu: Edit > Paste and Match Style.

And when you look at the Edit menu, does that show the keystroke to use when pasting? If yes, anything out of the ordinary?

Hi @holroy, thank you for answering my post!

It’s not when I just type, that’s all fine. It’s when I PASTE something, no matter from what source, it gets these weird [[() things around it, even when the copied text is NOT a link.

This happens in existing notes, and in new ones too.

But, I did what you suggested and in a sandbox vault with no 3rdparty plugins, it does NOT happen. Oh well, here we go again…turning everything on and off for the oompht time :stuck_out_tongue_closed_eyes:

I know the feeling. I’ve reinstalled Obsidian a few times today trying to get the installer to upgrade, and it didn’t at first. Then I tried solving some other issues, and just made a mess of it. But, that’s me and my problems.

Back to your issue, it could possibly help to post the Show debug info into this thread, so that someone (wiser than me) could potentially identify if a plugin (or which) plugin could be the culprit.

I reckon that you’ve already tried to update all of your plugins, to the latest version?

If you got multiple installed, it’s a pain to find the faulty one, but you could try disabling all, and then reenable half of them until you trigger the fault again. And then keep disabling and re-enabling half of the target plugins, until you narrowed it down to that icky thingy causing you grief.

1 Like

Could it be this plugin:

Referenced here:

1 Like

I don’t use live preview, don’t like it :woman_shrugging: makes me confused. But, I just disabled all my plugins and now everything seems fine, so it is one of them, I’m afraid… trying your advice to turn several back on at the same time instead of one by one.

If I find it - and I am starting with the one you suggested - I will report back here for future reference.

Yes, everything is updated, I usually do hit that button once a day :wink:

I’ll turn on Show Debug Info!

GitHub - chrisgrieser/obsidian-divide-and-conquer: An Obsidian plugin that provides commands for bulk enabling/disabling of plugins. Useful for debugging when you have many plugins. is helpful for this

Good hunting :muscle:t3:

1 Like

This was the one! Now I need to go see if that can be fixed. Thanks for thinking along!

It turned out to be not so much the plugin itself (which I find very useful) but a SETTING of the plugin. It should be as you can see in the picture, while I had somehow managed to choose another setting, which led to all the pasting I tried go wrong.

1 Like

That plugin didn’t seem to work for me, but nevermind, I found the culprit! It was the “paste url into selection plugin.”


Great news. :grinning:

Saw in another post that you had lost some data recently through a hardware failure. Hope your recipes were safe (tons of work in a recipe).

1 Like

I’m afraid they were not. But I have all my recipes also in an app called Paprika, so they’re not really lost completely, thank God!

1 Like

Felt my heart lurch downwards when I read that. So much work. Gone but not lost entirely.

I’m off to check my backups are sound.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.