I cannot get iframe to work

Hey all.
I’m trying to use an iframe tag (version 0.8.1) and I fail to make it work.
I tried many different iframe generators. but for the sake of simplicity here is an example:

<iframe src="https://todoist.com/app/#project%2F1770955882"> </iframe>

things I tried:

  1. closing and opening obisidian
  2. turning the css plugin on and off
  3. installing the new installer
  4. reverse psychology
  5. turning vpns and proxies on and off
1 Like

If you open Developer Tools, I think you’d see this:

Which is a security feature of Chromium (on which Electron apps are run), as explained here. I don’t know wether this could be made to work, but I think that’s why it’s not working.

nope nothing.

I remember seeing people successfully embedding Todoist with iframes, maybe you want to ask on the Discord? (Search there to see who’ve done it too.)

I don’t know what changed since then, but I tried again today, and it just worked! Awesome!

1 Like

I’m getting blank embed too… I’ve copy and paste official coda.io embed link.

<iframe src="https://coda.io/embed/rM2tDGHZVX/_suFAm?viewMode=embedplay&hideSections=true" width=900 height=500 style="max-width: 100%;" allow="fullscreen"></iframe>

Someone can help me figure?

I don’t know too.

(Sorry for ping) @moderators can help by putting this to #help section again. so others can help.

Even with version 0.10.10 it does not work

Same here with Coda.io – can’t force the iframe, even when the Coda doc is published. If Obsidian is my favorite app, Coda is my second fav, and I would be thrilled to introduce them!

1 Like

Everytime i see new update with iframe upgrade. I retry :crossed_fingers: but no… It just don’t work :frowning:

By the way how did you got your insider badge?? I’m one but with no badge!

1 Like

re: Insider badge – J’ai complètement oublié… I think there were some instructions somewhere. I should have made a note of it in my vault :wink: I noticed that others just asked one of the devs in the Help section here and they were able to turn it on.

syntax that works for me:

@manuel2108: Are you saying you got a Coda.io document to embed with an iframe? That’s the standard iFrame syntax you’re showing, but since you just wrote “link” I’m not sure you have actually had success with a Coda.io document. Can you confirm? Thanks

@delinos: I did not check with Coda. It certainly works with Todoist, Evernote,…

@Gadwood - I opened a bug report here. Please let me know if you end up figuring it out on your end. Thanks!

1 Like

I know I’m necroing an old thread here but I was just having issues with iframes and found out it’s because I wasn’t including the https:\\ at the beginning. Rookie mistake, but might save someone a headache some day.