How to turn off autoupdate on bullet points and numbered lists for DailyPlanner plugin

Things I have tried

  • Disabling ‘Smart indent lists’ in Editor settings
  • Tried looking for where the macros are (Couldn’t find it)
  • Copying and pasting the example page as shown in the ReadMe guide for the plugin
  • Reading the forum for help. E.g Disable automatic enumeration
  • Watching video guides on the Day Planner Plugin (How I Use Obsidian Daily Notes - YouTube)
  • Tried adding a backslash before the dash

What I’m trying to do

I am trying to get started with the Day Planner plugin but an auto-format setting for bullet points is causing me problems.

When I type a dash - it automatically converts it into a bullet point.
For the Day Planner plugin, times are recognised as: - [ ] 09:00 Example
Because of the autoformatting these times do not show when I open the Day Planner Timeline

How can I disable macros/autoformatting of text?

(I’ve just started using Obsidian today, I apologise if this is a silly question. Thank you for your help)