How to manually browse and install community themes and plugins?

I find that I could not access the community themes and plugins in Settings, and not able to login.
I guess I’m blocked by the windows firewall.
Because the firewall setting is locked by my company, I’m not able to allow Obsidian to connect to internet.
Of course I’m going to talk with some IT guy if it is possible to solve.
If not possible, is there a way that I can browse the themes and plugins on a web browser, and download and install manually?

I checked with IT that they helped me adding inbound and outbound rules for Obsidian in Windows firewall, but still didn’t work. Really need some workaround.

Hey, I had a look at Settings → About. The installer version and current version are different , and it’s saying the version is update-to-date. But I have never upgrade version on purpose after the initial installation, so probably “automatic updates” is working fine silently. So I suddenly realized that Obsidian maybe not blocked by computer firewall at all. Can anybody confirm this?

There was this thread:

It’s an older thread, but might be useful. Can you access that .json link? Could be a way to test your network access. The json link.

And here is the json that lists all the community plugins, or at least the ones that were submitted and approved to be listed. (Not sure about that process.) This json has the names and github urls of the plugins. You can pull and install these repos yourself.

There is also YourVault/.obsidian/community-plugins.json
community-plugins.json is in this format, if you are attempting to install manually:


And the plugins would go inside YourVault/.obsidian/plugins/NAME-OF-REPO



Thank you @rigmarole for the reply!

Yes, I can access the json link and the community_plugins.json in GitHub in my browser.

And I still have question on how to manually install the plugins. Sorry for so many questions as I just started using Obsidian.

I tried to put the community_plugins.json under MY_VAULT/.obsidian/, and restarted Obsidian. But nothing happened.

I also had a look at a plugin repo in GitHub, like Dataview. But I’m a bit confused that there isn’t an instruction for manually installing the plugin into Obsidian at a glance.

It turns out still the network problem.
It doesn’t work through direct connection, my company’s VPN also sucks…until I tried proxy and finally connected!

It’s like seeing the universe for the first time!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.