Hide spelling errors outside edited line

Use case or problem

When I type just a single world in a line the spellchecker sometimes marks it as incorrect because it cannot recognize language. It is distracting and I cannot fix it without adding some extra words (which is a bit artificial).

Example (the first word is correct; it is in Polish and it means “example”):

I noticed that Logseq hides spelling errors in lines that are not currently edited and it makes reading notes easier. I know that I could also switch to read reading mode after I’m done editing.

Proposed solution

Add option to check spelling only on edited lines.

Current workaround (optional)

Correct misspelling or add extra word to make spellchecker happy.
Switch to reading mode after done editing.

Related feature requests (optional)

1 Like