Help typing accented characters

I was trying to type some accented Ancient Greek characters into Obsidian and having some issues. I ordinarily have two ways of doing this, neither of which work in Obsidian. First, I use the “Greek (polytonic)” keyboard layout, which turns some of the keys (; ’ [ ]) into “dead keys”. Typing a dead key and then a letter is supposed to produce the accented letter, but in Obsidian the dead keys seem to do nothing.

Second, I mapped my Right Ctrl to a “compose key”, so that typing the sequence: Right Ctrl, ', α should produce ά. On Obsidian, the compose key does nothing and I just get 'α. (Maybe I should mention that this method is also supposed to work for Latin characters with diacritics, like é and ç; I also can’t type these this way in Obsidian.)

The characters themselves are ordinary Unicode characters and can be pasted into Obsidian with no problem. So if nothing else, I can write in a different text editor and paste it into Obsidian, but obviously it’d be nice not to have to do this.

Things I have tried

Based on some other posts I saw on this forum, I tried turning off “Auto pair brackets” and “Auto pair Markdown syntax”. I ordinarily use Vim key bindings, but tried turning those off too. None of this fixed the issue.

What I’m trying to do

I’d like to fix the problem, or at least understand why it’s happening! I know it’s pretty niche, but I wonder if anyone else has had similar problems typing other accented languages (French? Vietnamese?), and if so, whether you’ve found a decent workaround.

This reminds me of a bug report I have submitted recently: Obsidian handles some of the keys as if you were using the US English keyboard. Hence, Obsidian might think the grave accent was on the key just above the Tab key on the left hand side of the keyboard, [ and ] are the keys just to the right of the P and the semicolon just to the right of the L key. Perhaps this is of help to you.

I have included parts of the US English keyboard in my bug report, so you might look there for clarity.

1 Like

Thanks for the link – that does look relevant and it’s too bad they aren’t planning on fixing it. I am using a US English keyboard, just with a different keyboard mapping. (So keys that are marked as brackets, etc. on my hardware keyboard are supposed to act as dead keys.) I don’t think Obsidian thinks they’re still brackets, because it doesn’t produce a bracket when I hit the key (it just does nothing).

Sorry, I just checked again, and what you described is happening. The US-English [, ], and ’ keys are still producing those symbols. The semicolon key does nothing (maybe because the semicolon is mapped elsewhere (to the Q key) on the Greek keyboard layout).

Did you try to use Quick Add to map a custom hotkey to put your character? I use it for French accented characters.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.