Help! Obsidian Lags with Many Notes

What I’m trying to do

Obsidian’s performance noticeably declined after importing my 40,000 Evernote notes. With 50,000 notes total, the program lags significantly. I need to find ways to improve its speed.

Things I have tried

Enabling restricted mode has made no noticeable difference in performance.
Reducing notes to 10,000 restores expected speed. Any suggestions for optimizing performance with larger note volumes?

1 Like

i’d go with a fresh index


quit Obsidian

go to:
(or similar folder if you are on mac or linux)

remove these folders:

Code Cache

restart Obsidian, let it index afresh

maybe try deactivating dataview and omnisearch or any other plugin that do indexing on startup (if installed and enabled)
in fact, always activate any plugins after the indexing is done…

Thank you for your reply. I tried following your steps, but unfortunately, it didn’t resolve the issue. Is there anything else I can try? it seems Obsidian isn’t able to handle a large volume of notes.

1 Like

i’d check for potential problem files
e.g. base64 images (i had some of those in my evernote and ditched them)

also, try looking in the developer console (shift+ctrl+i) and try to look through it, maybe it’s a plugin

try deactivating comm. plugins and see if it’s any better and then switch them back on in the order of importance

Thank you for your reply.
I began troubleshooting by disabling all plugins, but the issue persisted. The Chrome developer console only showed browser interactions, not those with Obsidian. I’m currently unsure how to record my Obsidian interactions for further analysis. While I don’t have any base64 images, I suspect other problem files may exist, but identifying them requires more technical expertise than I currently possess. I’ll dig deeper into them.

I had an identical issue, with a research folder which topped out at around 40,000 notes, many with attachments, including jpgs, pdf and docs. I ended up splitting the vault into 3 vaults. Not ideal, but it solved the problem.

1 Like

i had to deactivate the graph core plugin as well (lag disappeared, mostly)
also, a more minimalistic workspace can speed up the vault

unfortunately, there can be a lot of unknown glitches…

@registereduser @Yurcee
Thank you both. This seems like our only option for now.

Good to know. Thanks.

I’d already noticed in a vault with only 9000 notes that I can’t leave the graph view open in a tab (even a tab that’s not showing), without getting noticeable lag in following a link and a one or two second lag in creating a new note. Now I know that there may come a day when I have to disable the graph view plugin completely. (I’ll file that next to my knowledge that various parts of my body will one day stop working.)


and if you turn off the files core plugin and use just the quickswitcher to fall back on to find files
or the various complements plugin while in a note writing
… beeeneficial

sad that core stuff cannot handle lots of notes…