Having Trouble While Installing Obsidian

Greetings to all, I am a new member on this forum and this is my first post here. I need some help friends. Actually yesterday I was tried to install Obsidian on my Windows 10 PC. But after completing the installation process when I run the software, I could not. There was some kind of error that did not allow me to run the software. I have no idea what could be the issue. Does anyone have any idea about this? Please help me.

Maybe there is something stopping Obsidian from running. See this post to compare behavior: Application won't launch after installation

Otherwise, you may have to just search the forum for other similar posts or provide further details and someone may be able to help.

Good luck.


My PC specification is similarly same. But I dont know why did the problem happening. Anyway after posting the thread here, I started searching online and found some post like [link removed]. I followed some useful methods from there. First I run the system troubleshooter then updated the Windows.

After doing the methods correctly, I tried to install this and I had no longer any issues while installing. Now I am working fine on there.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.