Graph viewer is not displaying graph

Heya devs. Thanks for Obsidian! I’ve been using it for a half year and I’m really enjoying it. For some reason though my graph viewer is now blank, and I’m not sure why.

Steps to reproduce

I opened up graph viewer, and it displays no graph.

Did you follow the troubleshooting guide? [Y/N]

Yes, I attempted to view the graph in the sandbox vault – no luck.

Environment

SYSTEM INFO:
Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: #38~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Nov 2 18:01:13 UTC 2 6.2.0-37-generic
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

Here’s what I’ve tried so far:

  • Complete app purge followed by reinstall (Debian)
  • Checking the .obsidian folder for any cache information to clear

Here are some related topics I’ve read through and checked against:

Worth pointing out, I’m using virtually the same Ubuntu distro on my laptop and I’m not having any issue viewing my graphs there. Let me know if the debug info from that device would be relevant to this post.

Same OS (Ubuntu 22.04) and same problem as you. I have also gone through all the posts, but I think there are sooo many Linux Distros it is hard to create one app that works for all and even harder to make multiple apps for each distro.

I feel this is the only place where Linux and Ubuntu are kinda disadvantaged.

Let’s try to pin it down to the specifics of what’s happening in 2024 March: Linux distro, window managers, hardware, etc.

The Situation

Basically…
On Ubuntu 22.04 LTS. Ever since Obsidian v1.4.1 and beyond, we have a problem of Graph View not displaying the graph rather a blank black screen. I am not sure of others, but I am using the snap version available on Ubuntu (not Flatpak or APT).

The Temporary Fix

A temporary fix is to turn Hardware Acceleration off and run graph view solely off of the CPU, but it is too taxing on the CPU and the fans turn into Drone/Jet Engines, temperatures rise, and eventually your computer is too hot. In short, we cannot do it for long enough.

My Proposed Actual Fix (where we are having difficulty)

Bigger problem is that there are no GPU cache files visible to clear/change. So it rules that option out (unless experienced folk can help us to find the said GPU cache files).
Clearing GPU cache should fix the issue. But where is Obsidian’s GPU cache file located in Ubuntu 22.04 LTS?

MY (WORKING) SOLUTION

I have found the solution!
Step 1: open up the home directory and enable “Show Hidden Files”

Step 2: Search “GPU Cache” and select the one with the path displaying “obsdian” folder in it (like the file selected in the screenshot below)

Step 3: Open this folder and Ctrl+A to select all files, and press delete to delete all files in this folder.

Close this folder, open Obsidian and if you reopen this folder again, you may see these files formed again but the error will be gone, don’t worry.

Enjoy Obsidian Graph View on Ubuntu!

1 Like

Thank you! This worked for me in Linux Mint 21.3 Cinnamon.

1 Like

Also worked for me on linux mint 21.3 cinnamon. this was driving me nuts - thank you!