Graph view not showing group colors

Steps to reproduce

  1. Open Obsidian
  2. Open Graph View

Did you follow the troubleshooting guide? [Y/N]


Expected result

Graph view with the nodes colored according to group conditions

Actual result

All nodes appear in the default colors (white for notes, pale yellow for attachments).


Obsidian version: v1.4.5
Installer version: v1.3.5
Operating system: Windows 10 Home 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

I tried the sandbox, and when I create a group (like path: Formatting) it does color the relevant notes. However, my real vault (still on restricted, and after several restarts) still doesn’t.
I searched the settings, but found nothing that might relate.

While I am not 100% sure, this seemed to have happened after the latest update to 1.4 (I work with the desktop version)

1 Like

There have been an update regarding the installer.

The latest available is v1.4.5 :

Note: The installer has been updated to use Electron v25.8.0 (requires downloading the latest installer).

(per the Obsidian’s changelog)

I honestly have no idea if it might help though :confused: …
But just in case, I thought I would mention it :innocent: (who knows ? :smiling_face: )

Unfortunately, this didn’t help with this problem. However, thanks a lot anyway! :grin: I completely missed that note in the change log!

I’m sorry to read that :pensive:.

UPDATE: I updated Obsidian on my MacOS and it definitely is a result of the update to 1.4. All the colors were fine before, then after relaunching with the update, there only the basic default colors.
Like windows, updating the installer to 1.4.5 does nothing.

What DID work was to Restore Default Settings in Graph View. After that, when I added a new group the colors update. So this is technically solved.
Of course, this fix deleted all my previous groups, which isn’t ideal, as I now need to redefine them and the colors.
For the sake anyone who still might try to figure this out (or experiences this issue), my only hypothesis is that maybe I had too many groups and that something went wrong because of it in the update. I recently did see obsidian “thinking” when loading the colors in graph view every now and then.
For context, I had about 10 groups (I am really like color coding :sweat_smile:). I don’t know how many groups most users have, but it seems like +10 might be unusual.

Anyway, the issue is resolved for me.

I have the same problem

I am also having the same issue on Windows 10, updated to 1.4.5.

I have the same problem. So I guess there is some bugs. I decide to roll back to version 1.3.7 and trun off the auto updating. Then waiting for the next updating to see whether this problem sovled. In fact, to me, version 1.3.7 is enough

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.