Graph view not loading a graph (Linux)

What I’m trying to do

When I open graph view, the UI buttons in the top right are there (for filters, groups etc.) but no graph itself.

Things I have tried

I did a complete uninstall and reinstall (used pacman as I’m on Arch) and created a new vault, made a couple of files and no graph appeared. I opened the sandbox vault, and the graph does not appear also.

Thanks in advance

2 Likes

Stating the obvious here, but did you check whether the plugin (core) is enabled?

I’m currently having the exact same issue.
Graph is just a blank view in both my main vault and in the Sandbox Vault.
Screenshots attached

As for the comment from @RiaGruen the Graph plugin is enabled by default and should show whenever the Sandbox Vault is opened.

I’m on Archlinux and installed Obsidian with with pacman from the extras repository

My Vault

Sandbox Vault

I’ve run into the issue myself yesterday. It miraculously cured itself after I closed the graph view, restarted Obsidian and only then opened the Graph again.

Unfortunately I have no idea whatsoever, if that was but a lucky coincidence :frowning:

Maybe this?

Oh I missed this topic about the problem, thanks for linking!
I’d be willing to bet that this is the issue.

@aiden1999 The pacman version has issues in general, sometimes it breaks, sometimes it doesn’t, but fundamentally it’s a GPU driver issue from what I could gather (see my thread that ariehen linked to).

The solution ultimately is not using the Arch version and pacman because ultimately they are just not supported. I’ve gone over to using the AppImage as it seems to be the most advertised format officially supported by Obsidian for Linux. The Flatpak could be an alternative as well of course, though it is community maintained so the guarantee of it working well is a smidge weaker.

Assuming you’re on Gnome and you want the AppImage to show up in your launcher, here is how I “installed” it:

  1. download the AppImage
  2. Install fuse2 and fuse3
  3. move the appimage file to /usr/local/bin
  4. Downloaded the obsidian-icon.svg and put it under /usr/share/icons
  5. Created an obsidian.desktop file under ~/.local/share/applications looking like this:
[Desktop Entry]
Name=Obsidian
Comment=
Exec=/usr/local/bin/Obsidian-1.4.5.AppImage
Icon=/usr/share/icons/obsidian-icon.svg
Terminal=false
Type=Application
StartupNotify=true
MimeType=x-scheme-handler/obsidian;

This should add the icon to your launcher same as if you had installed it via pacman.
Sadly you can’t “uninstall” via pacman that way.
Honestly I wonder why pacman, even if it can’t control updating an appimage, can’t at least manage installing/uninstalling it.

3 Likes

I create an tutorial in medium how to fix this bug in graph view.
https://medium.com/@williamjj/fix-bug-obsidian-graph-view-not-show-in-linux-c05696da69a5

I am facing the same issue since yesterday on my Ubuntu

Same issue here. It worked fine for almost a year and sometime in the last couple of months it stopped.

Happens in the sandbox vault as well. And I am using the official AppImage, no package managers or anything in the way.

I am using an NVidia 3080 Ti and I am able to play advanced games with zero iissues.

The PixiJS Playground works fine in Chromium and Firefox. Playground | PixiJS

This all tells me that it is extremely unlikely to be a driver issue.

It might have something to do with the way that Electron was configured or some other weird Electron edge case.

This issue is caused by Electron configuration as @acook mentioned. Specifically, under Wayland. By default, Electron applications try to run using XWayland (the compatibility layer with X11 applications). To fix this issue with the Arch package, simply create a file ~/.config/electron25-flags.conf and add the following contents:

--enable-features=UseOzonePlatform
--ozone-platform=wayland

This will make Electron applications run natively under Wayland and be able to find the correct drivers.

See the ArchWiki for more information: Wayland - ArchWiki

1 Like

I’m on X11, so it sounds like something could be done similar to the configuration to improve compatibility for all windowing systems.

Had issue of graph not appearing after installing a mass of updates on my Kubuntu 22.04

Replaced the Obsidian-1.4.[something].AppImage with the newest Obsidian-1.5.8.AppImage from the official website and the graph seems to be working fine now

I found the problem and the solution!

Problem

Due to a change in lib Mesa the GPU cache files are no longer compatible with previous versions. Trying to load the old cache files breaks Obsidian’s Electron from being able to successfully acquire a OGL context.

Solution

Delete ~/.config/obsidian/GPUcache.

To fix this problem for everyone and prevent it from happening in the future I propose that Obsidian purge the GPUcache during every update.

References

5 Likes

I just wanted to come on here and report that I’ve been having the same issue with my graph for what seemed like months. It wasn’t much of an issue, as I do not utilize the graph all that much, but I thought I’d search the forum here and see if anybody else was having these issues and found this thread.

I’m on the newest version of Linux Mint and have had the problems many of the others here mentioned. The proposed solution of deleting ~/.config/obsidian/GPUcache worked like a charm for me. I nuked the directory with Obsidian open, reloaded the app and alas, there was the illusive graph once again.

Thanks for everything you guys. This forum is always such a gold-mine!

Unfortunately the graph view is disappearing again. This can be replicated for me:

  1. Open Sandbox Vault
  2. Open Local Graph View
  3. Put Local Graph into Right Sidebar
  4. Close Obsidian
  5. Reopen Obsidian
  6. Observe the the Local Graph is broken

Console messages:

PixiJS Error: Could not initialize shader.
PixiJS Warning: gl.getProgramInfoLog() Program binary could not be loaded. Binary is not compatible with current driver/hardware combination. Driver build date Apr 14 2024. Please check build information of source that generated the binary.
WebGL: INVALID_OPERATION: useProgram: program not valid
WebGL: INVALID_OPERATION: drawElements: no valid shader program in use

Deleting the GPU cache is insufficient to fix the issue persistently, it will recur after the next program start, and it doesn’t fix the issue for my main vault at all. So there must be some other cache somewhere??

I just noticed this when running obsidian from the terminal.

Seems like this may be related?

2024-06-20 10:20:01 Checking for update using Github
DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.
2024-06-20 10:20:01 Success.
2024-06-20 10:20:01 Latest version is 1.6.3
2024-06-20 10:20:01 App is up to date.
libva error: vaGetDriverNames() failed with unknown libva error