The Graph is not showing

Steps to reproduce

1. open the general graph.

Did you follow the troubleshooting guide? [Y/N] Y

Expected result

Expect to see notes on the general graph.

Actual result

The overall graph is empty. There are no notes on it.


Obsidian version: v1.4.5
Installer version: v1.4.5
Operating system: #1 SMP PREEMPT_DYNAMIC Thu, 24 Aug 2023 00:38:14 +0000 6.4.12-arch1-1
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v7.2.1
Snippets enabled: 0
Restricted mode: off
Plugins installed: 4
Plugins enabled: 2
	1: Remotely Save v0.3.25
	2: Outliner v4.8.0

Additional information

First of all, this came out a little over a week ago. I tried uninstalling cache, reinstalling obsidian, changing themes, deleting everything from the .obsidian folder. Nothing has helped.

Below is what I see when I go into the graph.

It’s important to clarify that I can open the local graph in a note first and it will work. Then go to the general graph and it will also work, but much worse than before. There will be no “circles” on the notes, just links between them (“sticks”). Screenshot below.

You’re an arch linux user I take it? Did you install via pacman or did you install the appimage/flatpak?

1 Like


Afaik that one isn’t supported by the obsidian dev team themselves. Overall that one is a GPU driver issue with pixiejs, which is used to render the graph view.
If you’re curious about the rabbit hole that sent me to you can read here.

To see if your base reason is something similar, you could try opening the application and pressing CTRL + SHIFT + I to open the browser console (obsidian is in the end just an electron app, so basically it runs in a browser and hides the browser) and open the graph view.
Chances are high you’ll see some error about pixiejs being unable to initialize or sth.
Happened to me on arch as well.

Regardless of what it is though, the solution is to just jump to something that is actually supported by the obsidian dev team. That is on Arch either the AppImage, or the Flatpak (though that is “only” community maintained so AppImage is the most likely to be the most stable offering there).

Also if you’re on gnome and AppImages are meh because they don’t show up well in the app-launcher view of gnome, here’s a short guide for setting an AppImage up so that it shows up there.

1 Like

Thank you so much! Indeed, you are right!
The solution is not to install obsidian via pacman, but from the official website using AppImage.
Thank you very much!

1 Like

Hi there,

I’d been using Obsidian on Manjaro for a year or so flawlessly, but a few week ago I encountered the same problem as OP. I’m not sure if it happened after a system update, or after upgrading to a specific Obsidian version. In any case. At first I installed Obsidian from AUR, that worked, but only for a little while.

However, reading this I realized I can start Obsidian from the terminal by typing:

prime-run obsidian

Depending on your graphic drivers this could be a solution. It may also work if you are using NVIDIA Optimus.

I hope this gets sorted in future updates, regardless if that would be from the Obsidian team or the Arch community.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.