Graph View Lines Disapeared

I opened and closed the Graph view perhaps too quickly (20x’s) in succession.

It froze a moment. The screen turned black, flashed back with Obsidian displaying all my panes. In the Graph I zoomed in, words appearing floating in wild circles with no line rendering to anchor them. Upon zooming out the words disappeared and the lines did not appear. Leaving me with a black Graph View. Upon restarting Obsidian, the graph displays entirely just fine.


  • Operating system: Windows 10
  • Obsidian version: v0.8.15

Additional information

I can’t repro. Can you post a short video/gif?

I was going to try to reproduce and film, but now that obsidian has been updated with the graph revamp and it runs so much smoother, i think that this “bug” i reported is invalid. I’ll file a new report if I see anything else regarding v0.9.1.

I have the same problem, lines often disappear and when that happens, all I can see in the Graph view are the links floating (new to Obsidian, not sure of the terminology, but words surrounded by double square brackets, some kind of link)… only these link names show in the graph, the lines are all gone, and the circles that usually accompany the note name are also missing.

When this happens, so far the only way I’ve found to fix it is to close Obsidian and re-open it, and even then, sometimes I need to do this close/reopen sequence twice, 'cause sometimes just closing and reopening only once doesn’t resolve the problem, when I close and reopen, sometimes the graph view is still not working and I have to close and reopen a second time (and yes, when I close, I wait 4-7 seconds to make certain the application if completely closed before reopening it again).

Of course it’s behaving now that I would like to take a screenshot, so I’ll take a screenshot later when it acts up again (although, I did update to v0.12.3 earlier today, or late yesterday, so maybe I’ll get lucky and with this new version the problem will be gone).

Windows 7 Ultimate x64
Obsidian v0.12.3

1 Like

Nope, problem not solved, had it happen again this evening, clicked on Open Graph View, and I could see nothing in Graph View, tried zooming in and out, tried moving back and forth (holding down left-click in the graph window and moving mouse all over), but Graph window was empty, restarted Osidian, and Graph view works again.

This problem happens very regularly.

1 Like

You propably have an old/unsupported GPU. try to disable hardware accelleration in settings>about

1 Like

Ok, I’m going to try that and see how it works out. Thank you.

This worked for me.

Same here, so far I haven’t had the problem again, I’m going to mark this as solved. I’ll have to “un-solve” it if I get the same probs. happening again, or create a new post, but so far, I believe that disabling hardware accel. was the key.

Thanks WhiteNoise.

Edit: Oops, I thought there would be a “Solved” checkbox for me to tick, but I see none, I guess WhiteNoise, being the Moderator, must have some way to set this thread as/to “Solved”.