Graph View crashes Obsidian

The Graph View crashes Obsidian continuously. On my iPad. And after that on my iPhone as well.
What on earth could I have done to get this?
How can I remedy this?

Zsolt’s latetest video made me look at the Graph again. It started, but then Obsidian crashed. From that Obsidian keeps crashing during the start up.
Half a year ago Obsidian did this, but at that time it still came through startup, giving me a chance to choose a different view. I decided not to use the Graph. After the updates we had I had hopes, but it is worse. It crashes earlier.
I can’t figure out how to get the app out of its loop.

How many notes? Does it happen in restricted mode and default theme?

Notes : 8,500
Photos: 3,100
Theme: Default

  • though half a year ago probably still Minimal
    Mode: unrestricted, some 30-40 plugins

Can you post your “Show debug info”?

Make sure you’re all updated, including your installer and theme and plugins. But then you’ll really need to test turning off plugins to isolate if that is the problem.

If Obsidian keeps crashing on startup, it might be difficult to copy the debug info. “30-40” plugins does seem a lot for mobile.

@Stof What do you use to sync? iCloud or Obsidian Sync?

Do you have any iOS apps that can edit hidden files/folders? Textastic (paid) and Taio (free) both work fine and are easier than the command line ones. See:

If you’re confident it’s the Graph causing the issue, you could try to reset the graph settings. The file to move or rename is MYVAULT/.obsidian/graph.json

If you use iCloud you can move/rename this file from the Mac in the iCloud directory. If you use Obsidian Sync (depending on your sync settings) you may have to edit the file directly on iOS/iPadOS using one of the above apps.

NOTE​: this will reset any custom graph settings on both desktop and mobile (depending on your sync setup). It’s worth a shot.

1 Like

Thank you for your time and advice.
No luck yet though.

Indeed there is no way for me to get to the debug-info.

I removed Graph.json on my Mac. I have indeed parked the vault on iCloud.
On Mac after the removal Obsidian started with no hesitation.
After that I tried Obsidian on my iPad again. I still get the start-up in a loop: Start, Plug-ins, Vault, Cache, Workspace.
Workspace takes a while, but then aborts and I see Start again.
The process breaks somewhere near the end of the Workspace part, is my impression, because I saw at the end of one ‘cycle’ the beginning of the building of the Obsidian screen. I saw that only once.

I would very much appreciate other suggestions.

As rigmarole mentioned, you are going to have to get rid of (or turn off) a bunch of plugins to find out if they are causing the lock-up on iPad.

One benefit of using iCloud sync is you can make changes on your mac and they get synced out to all other devices (easier than dealing with the iOS/iPadOS Files app). One drawback is that you can’t have selective sync of settings like Obsidian Sync. Unless something has changed recently, by default, it’s all or nothing for iCloud sync.

When I used iCloud only, I had separate config directories for desktop and mobile, .obsidian and, because settings kept getting messed up between the two. This keeps settings/plugins/etc from desktop and mobile apart. This may be a pro or con for you.

30~40 plugins is probably fine on desktop, but I would never run that many on mobile (right now I have 7). YMMV. You can create the separate config folder in Settings > About and choose the one Obsidian uses there. iCloud will sync any number of them.

Another option that I haven’t tried is selective iCloud Sync → Exclude individual file in shared .obsidian settings folder from iCloud sync

1 Like

I got Obsidian working again.
Many thanks for the (mental) support!

I did uninstall Graph.json. Which didn’t help.
In desperation after a while I uninstalled and reinstalled the app.
That got me through the boot process!
But despite the removal of the plug-in, Graph continued to boot up where it left off, as if nothing was changed.
Which brings me to the question: Could that be the cache? If so, how can the cache be emptied?

After booting up, I couldn’t choose anything else, the screen just didn’t react, because Obsidian wanted to index all the files. With Omnisearch getting in the way on top of that; Omnisearch blocks even more than the indexing by Obsidian. I removed Omnisearch on my Mac. Finally, in Obsidian, I could click on the cross of the graph screen.

I did have (and have; now again selected) a separate config-file for my iPad Pro. Unfortunately, in an update, I had forgotten to change the name in that field in About | Advanced.
But the number or one of the plugins didn’t give the problem. I was using 37 plug-ins. Have been since late 2020. Never had any problems. The only one causing me problems since halfway last year is the Graph.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.