Folding issue: Hitting ENTER does not add new line / bullet if folded set is at the bottom of the page

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

  • Create a new page
  • Add a short outline comprised of any text, and then fold it
  • Attempt to add a new bullet after the above short outline; it’s not possible unless you hit ENTER 4 times

Expected result

When a set is folded, hitting enter at the end of that set should create a new line, bulleted if the previous set is a bullet

What do you expect to see after carrying out the steps above?

Actual result

Hitting ENTER does not add a new line or new bullet, unless you hit ENTER four times in a row.


  • Operating system: MacOS
  • Debug info:
    Obsidian version: v0.15.9
    Installer version: v0.15.9
    Operating system: Darwin Kernel Version 21.6.0: Sat Jun 18 17:07:22 PDT 2022; root:xnu-8020.140.41~1/RELEASE_ARM64_T6000 21.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Atom
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 4
    Plugins enabled: 4
    1: Natural Language Dates v0.6.1
    2: Tasks v1.11.1
    3: Paste URL into selection v1.7.0
    4: Dataview v0.5.41

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I can’t reproduce.

Post a screen recording of this happening in the sandbox vault.

Sorry, not sure how to post this in a sandbox vault (and Googling came up empty), but you can view the .mov file from my Google Drive

ok, I am not sure I consider this a bug. When you fold the list and you put the cursor after the ..., you are actually at the end of the list but still in the list. It’s as if the cursor is at the end of line of the last row.
ENTER → new list item
ENTER → unindent
ENTER → unindent
ENTER → new line

Please, open a feature request for this.

Oh! Okay, I appreciate the info, and I’m sorry to bug you (no pun intended) but… if I want to add a new line in cases like this, are there any workarounds in the meantime that are faster than hitting RETURN 4 times? :slight_smile:

No, the only faster way would be to unfold, and delete the indents.
This behavior bugs me too :bug::upside_down_face:

1 Like