FLATPAK: Javascript error occured in the main process (EPIPE error)

Once you’ve done the above, delete everything above this line.

Steps to reproduce

System:
LINUX FEDORA 39 (Gnome desktop).

Problem:
On launching Obsidian (Flatpak) I receive an EPIPE error report [I’ve pasted to the bottom of this report]. Closing the first error report just generates another identical one. This happens circa 5 or 6 times before Obsidian opens. All appears normal with the functionality of Obsidian as far as I can tell to-date.

Attempted fixes:
I’ve tried a number of other apps on my desktop and this is error remains unique to Obsidian. I’ve also tried creating an ‘out-of-the-box’ vanilla vault (restricted - no plugins, themes etc) closing & re-opening it. Then I reinstalled the flatpak and restarted my system; but no luck.

Did you follow the troubleshooting guide? [Y]

From Vanilla Vault:

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: #1 SMP PREEMPT_DYNAMIC Mon Feb 5 22:21:14 UTC 2024 6.7.4-200.fc39.x86_64
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

Expected result

Actual result

Environment

Normal Set-up:
SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: #1 SMP PREEMPT_DYNAMIC Mon Feb 5 22:21:14 UTC 2024 6.7.4-200.fc39.x86_64
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: light
Community theme: Dracula Official v1.1.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 29
Plugins enabled: 24
1: Dictionary v2.22.0
2: Iconize v2.10.0
3: Paste URL into selection v1.7.0
4: Templater v2.2.1
5: Wordy v1.3.1
6: Excalidraw v2.0.20
7: Homepage v3.7.0
8: Dataview v0.5.64
9: Editing Toolbar v2.4.0
10: Better Word Count v0.10.1
11: Footnote Shortcut v0.1.3
12: Stille v1.3.4
13: Todo sort v1.0.0
14: Auto Note Mover v1.2.0
15: Custom File Explorer sorting v2.1.7
16: Clear Unused Images v1.1.0
17: Juggl v1.5.0
18: Toggle Case v1.1.0
19: Note Refactor v1.8.2
20: File Color v1.1.0
21: Paste From History v1.1.0
22: Editor Width Slider v1.0.5
23: Update time on edit v2.4.0
24: Local Images Plus v0.15.9

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

Uncaught Exception:
Error: write EPIPE
atafterWriteDispatched (nodeinternal/stream_base_commons:160:15)
atwriteGeneric (nodeinternal/stream_base_commons:151:3)
at Socket,_writeGeneric (node:net:930:11)
at Socket,_write (node:net:942:8)
atwriteOrBuffer (nodecinternal/streams/writable:392:12)
at_write (nodeinternal/streams/writable:333:10)
atWritable.write (nodeinternal/streams/writable:337:10)
atfn (/app/resources/app.asar/mainjs:57:10)
atrunUpdate (/app/resources/app.asar/main.js:151:
at update (fapp/resources/app.asar/main.js:139:9)
Ok

error

In the bug report template:

  • For Linux, we only accept bug reports that are reproducible with our Appimage package under Gnome or KDE.
1 Like

I have this issue too. I only noticed it when the Flatpak was updated earlier this morning. It’s currently v1.5.3.

Edit: the snap and appimage work fine for 1.5.3, the issue is with the Flatpak.
I noticed the reply from ariehen but wanted to let the OP know it’s not just them.

3 Likes

Thank you Phil200 for taking the time.

1 Like

Same thing here, also with the Flatpak.
I guess there is nothing to do except wait for an update?

Go here:

1 Like

Please update as such:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.