Failed to load community plugins

Steps to reproduce

click settings->third-party plugin->community plugins->browse

Expected result

I want to see plugins list and get the Public plugin.

Actual result

it didn't show me any plugin, and a info shows "failed to load community plugin".

I paid for it and can’t publish my notes.

Environment

  • Operating system: macOS Catalina 10.15.7
  • Obsidian version:0.9.10

Additional information

I am confused exactly what you are asking? Do you have problem with third-part plugins?

Did you purchase obsidian publish (which is not a third party plugin)?
If so, follow this guide:

I did see this guide and follow its instruction: From within Obsidian > Settings > Plugin, enable the Publish plugin.
My problem is: I cann’t enable it. Info shows “Failed to load community plugins”.

can you post a screen recording?

Third party plugins (settings->third-party plugin->community plugins->browse) should not be confused with publish
(Obsidian > Settings > Plugin, enable the Publish plugin)

were you able to make things work?

Let us know if you’re able to get it work. Sounds like you need help rather than filing a bug.

If you paid for Obsidian Publish and want to get started, don’t go to third-party plugins, go to “Core plugins” instead. It’s an official core plugin, not a third-party one.

I hope that helps!

1 Like

/solved. Thank u all so much!

1 Like

I got the same error. I just intended to see the list of third-party plugins, but it doesn’t load it. I’ve tried several times and I keep getting the same error: failed to load community plugins.

2 Likes

me too

Same issue - failed to install plugin. I get the same result even if plugin is downloaded manually and copied into plugins folder. Plugins are inactive and when I try to activate message comes up as “failed to load plugin Plugin Name”

1 Like

I have the same issue as Girmis. I tried to install the Templater plugin, but it keeps telling me ‘failed to install plugin’.

fixed in 0.10.11

2 Likes

I updated and it works fine now. Thanks!

updated the installer to v0.10.13 on mac os mojave, but the community plugins page still shows ‘failed to load community plugins.’

are you behind a firewall?

Nop. Have tried VPN connections. The network connections are fine but still get the same error.

I met the same issue. Just installed yesterday and confirmed not network issue.

OS = Mac OS Big Sur 11.2.1
Obsidian = v0.10.13

Snipaste_2021-02-16_17-00-08

same problem, can’t get any community plugins from browse

If you are behind a firewall you need to use a VPN or manually install the plugins