Export to PDF not working with Version 1.1.9

I’m using Obsidian in a Mac with silicon M1, MacOS Monterey. I updated to the newest version of the Obsidian app (Version 1.1.9) and now I cannot export to PDF. Is anybody else encountering this problem? Obsidian show a pop up window saying the PDF has been exported to the assigned path but when you go to that folder, there is no PDF there.

Things I have tried

  • Given Obsidian Full disk access


I managed to export the md file as PDF in Marked 2 but the images contained in the document had disappeared.

I am also working with Version 1.1.9 on macOS but using Ventura 13.1 with Intel. I am not experiencing any problems with exports to PDF.

Can you post your “Show debug info”?

I’m on M1 too. And I don’t have trouble with exporting.

This is strange. Here’s what “Show debug info” shows:

	Obsidian version: v1.1.9
	Installer version: v1.1.9
	Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:19:52 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T6000 21.6.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: off
	Legacy editor: off
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


That is: apparently nothing. But nothing is what I find in the folder where the exported PDF is supposed to be.

Have you tried a different folder?

Or test with the Sandbox vault and see if it works. Maybe there is a glitch in the specific note you’re trying to export.

OK, I did change the default Vault and created a new one in a Google Drive folder. The folder where I want to export the PDF is under Downloads in my home directory. What would I have to do to test it with the Sandbox vault?

So, I still have not been able to solve this problem. It doesn’t have to do with the document. I have made various tests with very simple notes and none of the is actually exported as PDF even though everything seems to work fine and I get a message saying the document was successfully exported. Any recommendations as to what to do to try to fix this problem?

I have other PDF issues (:sob:) but using macOS 12.6.2 and Obsidian 1.1.9, I’m able to export.

As rigmarole said, have you tried a different export location (e.g., Desktop)?
Have you tried using the Sandbox Vault (Help>Sandbox Vault) and exporting?

Yes, I just managed to export to PDF using the Sandbox Vault. But I’m unable to export that PDF outside the Sandbox Vault.

If it works in the sandboxed vault, that points to a problem with a plug in. Try disabling community plug ins, and CSS scripts, and try 1/2 of your plug ins, retest to see if it works or not, then try the other 1.2 of your plug ins and test. in 1 of those halves, it will not work, then you need to try to divide the 1/2 that didn’t work into halves, and eventually, you will find the plug in causing the problem. Good Luck :slight_smile:

1 Like

Thanks BarryPorter13. This doesn’t seem to be the problem, though. I disabled all the plugins and I still cannot get it to export PDFs. What’s strange is that I always get the popup window saying “PDF saved to path-to-directory” as if everthing went fine. But it didn’t.

Did you restart Obsidian after turning off the plugins?

1 Like

Any other antivirus or firewall apps that might be blocking? (Unlikely if the Sandbox vault works.)

Also if this wasn’t suggested yet, in Obsidian open the developer tools and console. Check if you see any errors when exporting.

And here are some additional threads to read, and check if they are applicable. These might be completely irrelevant to you, but I am including them just in case:

Do you have the note (or any note) open in Acrobat Reader, or another PDF reader? Export to PDF silently fails if PDF is open in Acrobat Reader

Is your vault, your main HD, or your write location on a network share? This might be relevant if you are testing in Google Drive, but I don’t know if that is a “network share”. Obsidian fails to render .pdf when accessing a vault via windows network share

1 Like

Yes. Not only did I restart Obsidian but I even restarted the computer. Same problem. I even did what I’ve done when I’ve experienced some other problems with my Mac: deleted all the contents of the cache folder and restarted the computer. The problem continues. Obsidian keeps on telling me the PDF has been successfully exported, the “Show Debug Info” says everything is hunky dory, but the PDFs are nowhere to be found.

1 Like

Thanks for your help, guys. This is driving me crazy. In response to rigmarole about the Sandbox vault, here’s the thing. This morning I rebooted my computer and tried again to export a PDF. This time I didn’t manage to export the PDF even in the Sandbox vault.

I’ll check now the other suggestions and report back but I thought this piece of information (that it also failed to export in Sandbox vault) could be relevant.

Thanks. I did this. The developer console doesn’t show any activity when I export the PDF. Shouldn’t there be a log of all the activity in the console? It is totally blank.

No, but this is interesting. With previous versions of Obsidian, when I exported to PDF, the PDF was opened with the default PDF viewer (Preview in my case). This is obviously not happening now. I had other PDFs loaded in the viewer so I tried again closing Preview. The problem persists, though.

Actually, my Obsidian vault is indeed in a Google Drive folder. When I installed the new version of Obsidian in this computer. I made that folder the main vault for my documents. I had not thought about this but this might be related to the problem. My memory fails but I think I was able to print PDFs when my vault was in a local folder.

So, two things changed before I started to have this problem: a) that I installed the newest version of Obsidian and b) that I made the vault I had created with my laptop in Google Drive also the vault for the Obsidian installation on my desktop computer. I attributed the problem to the new version but perhaps the location of the vault has something to do with this.

OK. I seem to have managed to solve the problem. I say “seem” because solving one problem has created another one.

Since I suspected that the Google Drive folder where I had the vault was the problem, I tried the following. I saved all the contents of the vault (two subfolders with .md files) and deleted the vault. I then created a new one (in the same Google Drive location but with a different name). I then moved the subfolders with the .md files into that new vault.

Now, I finally can export PDFs!

But now the problem is with my laptop. When I opened Obsidian in my laptop, it had “magically” figured out that the old vault did not exist any more and I could see all the .md files of one of the subfolders in the vault. The path coincided with the new vault I had created on the desktop computer. Alas, the visible contents were only those in the subfolder containing the documents I had been working on with my laptop.

I then tried to ‘Open another vault’ with the intention of making the main vault folder be seen as a vault and then be able to work with the contents of all the subfolders. This is the error message that appeared on my screen:

An error occurred while loading Obsidian. Error: ENOENT: no such file or directory, scandir'/Volumes/GoogleDrive/My

I should say (because it is perhaps relevant) that the Obsidian version I have in my laptop is an older version (v0.13.33)

I should also say that I installed the latest version in the laptop and when I try to open the new vault containing the two subfolders, I get the popup window showing that error message. This popup window has two buttons (‘Reload app’ and ‘Open another vault’). If I click ‘Reload app’, nothing happens. It stays there. If I Open another vault which is not the one I created in my desktop (for instance the subfolder containing the documents I had been working with), the vault will open in another window (another instance of Obsidian) and I will be able to work with it. The popup window showing the error does not disappear, though. It continues there with a moving bar and showing the error message.

TUTORIALS is the subfolder it can open and it is a subfolder of the new vault I created called OBSIDIAN_VAULTS. This is what I see on the left column when I try to open a new folder. If I click on the last one (the one I want), the error message appears. No problem with the other ones.

/Volumes/GoogleDrive/My Drive/_SYNC/OBSIDIAN_VAULTS

Zettir Tutorial

/Volumes/GoogleDrive/My Drive/_SYNC