Exclude Uncreated still shows first in link suggestion

Steps to reproduce


  • Enable Quick SwitcherShow Existing Only
  • Add your templates folder to the excluded files list under Files & Links

Make a template file. My folder hierarchy is /planner/YYYY.MM.DD.md

In the template file planner-monthly, I have:

# {{date:MMMM}}
[[planner/{{date-1M:gggg.MM}}.md|<< Prev]] | [[planner/{{date+1M:gggg.MM}}.md|Next >>]]

## {{date-1M:MMMM}} Backlog

## [[planner/{{date:gggg.MM.[Wk]w}}.md|Week {{date:w}}]]: 

## [[planner/{{date+1w:gggg.MM.[Wk]w}}.md|Week {{date+1w:w}}]]: 

## [[planner/{{date+2w:gggg.MM.[Wk]w}}.md|Week {{date+2w:w}}]]:

## [[planner/{{date+3w:gggg.MM.[Wk]w}}.md|Week {{date+3w:w}}]]: 

## [[planner/{{date+4w:gggg.MM.[Wk]w}}.md|Week {{date+4w:w}}]]:

Make a few new notes in this style, just to have some tests:

  • planner/2023.05.20.md
  • planner/2023.05.22.md

Now, go to a new note. Type the double-bracked [[planner/ and look at auto-complete suggestions.

Actual result

You will see the following, with all of the uncreated links first, before the files:


Expected result

I’d expect to see my links to actual files first. Especially because the Quick-Switcher setting (show existing only) and mainly because of the Excluded files means “less noticeable in Link suggestions”.

I understand settings for Quick Switcher aren’t the same used for link suggestions (I think they should be), but the excluded files relevancy means that these links (especially to dead links) should be lower in the list than my actual files which exist in the folder!


Obsidian version: v1.3.4
Installer version: v1.2.7
Operating system: Windows 10 Enterprise 10.0.19045
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 6
Restricted mode: off
Plugins installed: 38
Plugins enabled: 26
1: Highlightr v1.2.2
2: Kanban v1.5.3
3: Better footnote v1.0.1
4: Calendar v1.5.10
5: Emoji Shortcodes v2.2.0
6: Mermaid Tools v0.2.1
7: QuickAdd v0.23.0
8: Outliner v4.6.7
9: Convert url to preview (iframe) v0.5.0
10: Rich Links v1.2.0
11: Diagrams v1.5.0
12: Advanced Tables v0.18.1
13: Excel to Markdown Table v0.4.0
14: Tag Wrangler v0.5.8
15: List Callouts v1.1.4
16: Periodic Notes v0.0.17
17: Local Images Plus v0.15.2
18: Tasks v3.5.0
19: Dataview v0.5.55
20: Auto Link Title v1.4.1
21: Paste URL into selection v1.7.0
22: Custom File Explorer sorting v1.7.2
23: Note Refactor v1.7.1
24: Image Toolkit v1.3.1
25: Hotkeys for specific files v1.3.1
26: No dupe leaves v0.0.8

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This is my “planner” folder:

And “assets” folder hierarchy for templates stored:

Search/open a feature request for this.

Search/open a feature request for this.

Also you have to understand that you added the notes in templetes to the exclusion list, not planner/{{date:gggg.MM.[Wk]w}}.md

Ah, drat… That’s unfortunate. Do exclusions work with any wildcards? Like planner/{{* ?

That seems like a really bad flaw in the exclusion list policy. I’m not really sure what I’d want to replace it, but having to specify that every templated [[planner/{{date:gggg..... is excluded seems really bad. I certainly don’t want to exclude the planner folder, because that’s where all of my files actually live.

Thought it might be a bug; guess not — I’ll open a feature request. Thanks!

You can use regular expressions (marked with a slash at the start and end) in the exclusion rules.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.