Error: This path can not be resolved: contetn://sushi.hardcore.droidfs.volume_provider/tree

Steps to reproduce

i wanted to use droidfs in android as gocryptfs ecnrypt/decrypt files.
obsidian cant use droidfs intent uri direcotry as its vault.

you can get more details here :
Getting Obsidian to access DroidFS storage? · Issue #258 · hardcore-sushi/DroidFS (

❝Unfortunately, the bug comes from Obsidian, not DroidFS. According to the error message, it seems that Obsidian tries to retrieve a file path from the encrypted file inside the DroidFS volume. However, this file has no path on disk, as it is stored encrypted and decrypted on-the-fly in memory. As a result, the resolving process fails. Obsidian should instead copy the file into memory from the URI provided by DroidFS and work with this copy instead of a file. This is the standard way of sharing content between applications on Android. You can send a bug report to Obsidian’s developers❞


obsidian android version : 1.5.8
android version : 10
droidfs versrion : 2.1.3

nothing ?

This isn’t something we support, so the bug report category is not the appropriate one.
Moved to help section.

I am not familiar with droidfs, but simply by reading the first live of their readme

An alternative way to use encrypted virtual filesystems on Android that uses its own internal file explorer instead of mounting volumes.

I don’t think that this is something that is going to work. Obsidian needs filesystem level access to a whole directory (and relative api provided by filesystems, such as real-time file watching). The “uses its own internal file explorer instead of mounting volumes” makes me thing that droidfs doesn’t provide that.

what should we do ? who can help ? this is probably can be fixed.
please see this video in slower speed. (1.9 MB)
as you see i can add droidfs storage to other filemanagers like mixplorer or material files and can create file/folders.

i also checked if i can use my connected usb to phone as vault or not, it also has same error. it means obsidian dont support uri directory. some directories dont have a path, like (/sdcard/obsidian).
if you think its a bug please back it to bug-report section

Content uri aren’t real file/directories. We operate on real file/directories and associate filesystem primitives. You can open a FR for this but it’s not something it’ll be considered in the short term.

1 Like

thanks for response. i hope you fix this issue to use external hard drive (ssd/hdd) or usb as vault, if you solve this, probably using uri share-storage from other apps also will be ok.
im not talking about sd card, i know for sd card in android 10 can solve with using android/data/md.obsidian directory. external storage and usb stick storage is different.
[Bug] Can’t write to SD card (external storage) - Bug graveyard - Obsidian Forum
actully this bug did not solved for usb or external hard (ssd hdd).