Error during Sync setup on iOS - failed to load remote vaults

What I’m trying to do

I am trying to set up sync on my iPhone (iPhone 11, iOS 17.5.1). I just got my Sync account working on my Macbook today thanks to changes in v1.6.3 see this thread. I followed the Obsidian Help instructions to Set up Obsidian Sync on another device. After signing in and selecting the remote vault I get the following error: Failed to load remote vaults.

Things I have tried

“failed to load remote vaults”
failed to load remote vaults
failed to load remote vaults sync
failed to load remote vaults ios

I deleted Obsidian from my iPhone and my vault from iCloud before starting. I tried restarting my Macbook and iPhone before doing the following:

I open Obsidian on my iPhone and click Setup Obsidian Sync. (The other two options are “Create new vault” and “MyVault”.) This action deviates from the second step on the Obsidian Help document I link to above which says, “2. Select Sign in next to Open vault from Obsidian Sync.” which isn’t an option.

I sign in including entering my 2FA code. Then I press “Connect” on the screen shown below (which is the same as step 6 from the docs):


After pressing Connect I get the following screen to “Create new vault” and I click the “Create” button using the default Vault name (I made my local Macbook vault and my remote vault have the same name of “MyVault” since I only plan to have one vault.)

Then I get this red error message saying, “Failed to load remote vaults,” as shown here:

I press the “x” and it takes me to a log in page like this:

I press fill in my login credentials and then it displays a disintegrating purple square for a split second before returning to the above screen. This screen is also what happens if I initialize the iOS app with the Create New Vault option and then navigate to the Sync settings in the Core Plugins menu.

Pretty stumped.

What version of obsidian do you have on ios?

v1.6.2 (142)

Check if 1.6.3 is available in the app store.

It wasn’t available last night but is now! And it’s working! Thank you!