Account Login Not Working

What I’m trying to do

I’m trying to log into my account in the app on a Mac. I just bought Obsidian Sync after months of headaches from iCloud, and this is basically the first step of turning on Sync. Not the start I was looking for.

I’m using a local vault that I just copied from my iCloud to my local Macbook macOS v12.7.4.

After I enter my email address and password, I see a purple square disintegrating for a half second and then the login pop-up window disappears and I’m left at the settings menu again, which says I’m not logged in.

After buying sync I also turned on 2FA which isn’t asked for during login.

Things I have tried

I’ve searched the help docs for:

  • login not working
  • new sync not working
  • new sync login

I’ve restarted my computer.
I’ve deleted the app and supporting file folders using AppCleaner and re-installed it using v1.6.2.
Login on Obsidian website works and includes prompt for 2FA

1 Like

Exact same steps and issue here (bought sync on Mac, turned on 2FA, now not able to log in). Am using v 1.6.2 of the Mac app.

1 Like

It works now! It took another restart and v1.6.3, and the login worked! I was prompted for the 2FA code and everything.

Was fixed in 1.6.3

1 Like

It is still not working for me. Am using v1.6.3 and windows. I have tried multiple restarts and have 2FA on.

what does it say? are you sure you are entering the right password?