Hi Helpers!

I am currently trying to move a folder I made into another folder which all I would do is drag and drop and it would move into where I drop it.

Today somehow it is no longer working and just doesn’t do anything when I try to move it…

What would’ve caused this and how can I fix?

  • Tried opening and closing
  • Shutting down my computer
  • Updating obsidian to the latest version

PLEASE HELP - as this is one of the most basic needs for daily use that is now broken :frowning:

Try the rest of the debugging steps.

Hi @CawlinTeffid

It is frozen when I try to click on anything… I really don’t know what is happening with it.

Quit Obsidian, use your system’s file explorer to move the hidden .obsidian folder out of your vault(s), and start Obsidian again.

The .obsidian folder contains the vault’s settings, themes, and plugins; moving it out will set your vault back to its defaults. If that fixes the problem, you can add the old settings back gradually to see if you can find the source of the problem.


Just tried it… Now it is saying the error: ENAMETOOLONG - but i made sure to check the total characters of the file path including the / 's and it literally is way under the character and file path limit for MAC OS.

I don’t understand why it is doing this, I tried restarting it and taking the folder out and renaming, but when it opens and I add it back in, the whole Obsidian freezes.

This really is super confusing on why it is happening so randomly.

Please help :slight_smile:

This is when you try to move a folder in Obsidian?

Which folder? The one you were trying to move before or the .obsidian folder?

Either way, did you check the total file path length of everything inside the folder (and any of its subfolders, etc)?


I mean a folder in the Obsidian window where you see all your folders and notes, and before you could drag and drop another folder into another folder like copy and paste with no issue. Now it doesn’t even let me do it anymore…

Is there anyway to bypass the limit of 4gb ram for usage by Obsidian?

Since my library is growing fast with many media files stored inside and third party plugins - this is really slowing my performance down…

Please help as this is something that is really limiting the use of Obsidian long term!

I’m not sure that Obsidian imposes a RAM usage limit. Is this an OS limit?


This is what I found and currently am also dealing with it frozen and not able to move at all…

1 Like

Does restarting Obsidian clear the freeze?

Once you get the freeze sorted out it would help to describe the slowness you’re seeing (like, what actions are slow?). It would also open the command palette, run “Show debug info”, copy to clipboard, and post the result so we have some context.

Hi @CawlinTeffid

The whole screen just freezes. Anything you do doesn’t work or allow you to do anything like click or scroll in Obsidian.

When I exited and even shut down my computer and also tried deleting and re installing Obsidian and also trying that on the vault folder - the message it says on the start up is EFILENAMETOOLONG ERROR message and I can’t even get inside it.

Plus I really want to know is it true that there is a 4gb ram limit and regardless of your computer specs it will just crash and not be able to utilize anything beyond 4gb of ram?

Thank you so much for your help :slight_smile:

Let’s set aside the RAM limit question and deal with the freezing first.

Close Obsidian, use your system file explorer (Finder, Windows Explorer, etc) to move the hidden .obsidian folder out of your vault, and start Obsidian again. Does that help? (The .obsidian folder contains the vault’s settings, including all of its community plugins, so when you open the vault it will have default settings.)

Hi @CawlinTeffid

I tried that - no difference…

I really want to make sure the ram topic I mentioned - since if that is true that would be a major flag for me to continue using, can you please confirm with me if this is true, I am also using the 64 bit version for mac.

Thank you so much for your help :slight_smile:

I can’t confirm the RAM limit. I don’t think Obsidian deliberately limits its RAM use — I’m pretty sure the only constraints on its RAM use are external. The other person was using DataView or something — maybe there’s a limit on how much plugins are allowed to use. Or maybe their computer has low RAM, or other apps were using the needed RAM.

When you start Obsidian, try closing your vault and creating a new one.

You’re having three (or more) posts revolving around issues with your vault and the “EFILENAMETOOLONG”. Since this is the only error messages you’ve actually received I think that should be your focus. Not moving folders, nor any potential ram issue.

Why do you get that error message, and to which file(s) do it relate?

So have you looked into the Developer Tools, and the console pane therein, and what does it report?

1 Like

OK, yeah, I’m going to merge these threads under a new name. Is the other thread its own thread, or do I remember right that it’s comments on someone else’s thread?

Renamed this thread from “Moving Folders inside to another folder… NOT WORKING” and merged the “Obsidian ram limit” thread into it, to focus on the main error.


It usually happens on the most recent folder I create before existing out of Obsidian and the the next time I get back on and open the message would show.

The only solution I’ve been able to accomplish was deleting the folder, but in my case it would still show me this message for the 2nd most recent folder I made all the way repeating all the folders I made in my last session.

I only think the best way possible is once I am in after deleting all the folders is to never close my computer or Obsidian ever again in order to prevent this from happening.

Is it bad to never close your computer like the method I am proposing?

Please let me know :slight_smile:

And do you see anything in the Console at any point?

And there is no need to mention me when I’ve already answered to a post. I’ll get notified anyways.