Emojis have no margins next to text on mac

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

  1. Create a folder
  2. Add Emoji before text

Expected result

Obsidian 2022-04-19 at 23.49.59@2x

Actual result

Obsidian 2022-04-19 at 23.50.56

Environment

  • Operating system: MacOS 12.3.1
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.14.6
    Installer version: v0.13.23
    Operating system: Darwin Kernel Version 21.4.0: Fri Mar 18 00:45:05 PDT 2022; root:xnu-8020.101.4~15/RELEASE_X86_64 21.4.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on

RECOMMENDATIONS:
none


Additional information

I see similar bug reports in chromium from a few years ago, not sure if its related to chromium on MacOS. It also seems to render fine on the Macbook Pro’s retina display but not my external non-retina display, not sure if its a DPI issue. None of these issues show on windows
https://bugs.chromium.org/p/chromium/issues/detail?id=596223&q=596223&can=2

This text will be hidden

1 Like

Same Problem here on a MacBook Pro with Monterey 12.4 and no retina display:

This does not only happen for file and folder names, but also in the notes.

This is particularly annoying when you sync with Windows where they do have a margin, because it looks differently. On the Mac you need a space char to separate the emoji from the text, on Windows you don’t.

Mac with Monterey and no retina display:

PC with Windows:
win

The fonts look different, is this just a font issue?

In both cases the base theme is used with no custom font applied. But even when I set the text font explicitly to Arial on both systems, the problem is the same.

I think @Halderen is right, it has something to do with this Chromium bug. It has been claimed that it is fixed in Chrome 102, but I could not test it, since the current Obsidian installer comes with Chrome 100 only.

I could reproduce the problem on a Mac with no Retina display in Obsidian 0.15.2 (Electron 17.1.1 with Chrome 98.0.4758, and also after re-installing with the latest installer in Electron 18.3.0 with Chrome 100.0.4896).

Maybe it will be solved automatically when Obsidian updates to Electron 19.0.0 which comes with Chrome 102.0.5005?

ok, thanks.

@Cito how are you determining which Chrome build comes bundled with each Obsidian installer version?

@luckman212 you can see this in the developer console which you can open with option-cmd-i, by entering navigator.userAgent.