Embedded PDFs export as blank space (sometimes)

I am aware of the fact that this is more or less a duplicate of this report but as it appears that the bug persists despite the promise of it being fixed in 1.3.6 I will post it once more

Steps to reproduce

So far it has proven to not be the most consistent bug ever. Here’s the most consistent way I could make it happen:

  1. Create a new vault with default settings etc.
  2. Create an empty note
  3. Add a PDF-file to the vault such that it can be accessed with commands and be embedded into files (my PDF happens to be in landscape mode, don’t know whether that makes a difference here). Link to the PDF I used
  4. Embed some page of the PDF somewhere in the note (using the ![[<file>#page=<page>]] syntax), preferably with some text before/after the embed to make it easier to distinguish when exporting.
  5. Embed another page somewhere else in the note following the same procedure as in 4.
  6. Export the PDF as A4 to somewhere on your computer (the other formats do also share the bug, I believe).
  7. Open the resulting PDF.

Did you follow the troubleshooting guide? [Y/N]

Haven’t been in sandbox mode, only fresh vault

Expected result

I would expect the exported .md file to be accurately exported as a PDF with all embeds present in said resulting PDF.

Actual result

In the resulting PDF, one, both, or none of the embeds will be missing, and will instead have a blank space where the embed used to/should be


Obsidian version: v1.5.12
Installer version: v1.4.13
Operating system: Windows 10 Home 10.0.22631
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

OS in Environment is wrong, I am running Windows 11 Home, 23H2 (22631.3447)
Reproduction on video: https://youtu.be/xr5EbRFKgr8