Drag and Drop Links

Things I have tried

What I’m trying to do

In the docs under drag and drop (Drag and Drop) it says…

“You can drag and drop any files from your native file explorer to have Obsidian import (make a copy of) those files in your vault’s attachment folder and insert them as internal links. Hold Ctrl to create file:/// absolute links to those files instead of importing a copy.”

On the mac client holding ctrl when dragging in a file does not create an absolute link to the file but instead copies it to the attachments folder. I have tried holding CMD, option, ctrl and various combinations of each of those with no luck. Not sure if this is a bug or I’m just doing something wrong.

Assistance would be appreciated as manually creating these links is cumbersome and time consuming.

Thanks
-Len

Hi @len3 I was able to create a link to a file on my Mac by pressing ctrl + shift and then dragging the file from the Finder. Clicking on that from the reading view opens the file up in the associated application for the file type.

Give that a try.

Hey @dugdun,

I just tried that and it didn’t work. Here are some additional details if that helps. I am using the live preview editing mode and I’m on macOS Monterey 12.1 on apple Silicon.

I could post a video clip if that helps.

Unfortunately it looks to be an issue using the live preview mode. I just switched to that mode (I prefer the legacy mode) and I am not able to drag and drop to create externally linked files anymore. :frowning:

Thanks for verifying. Do you know the best way to report it?

Looks like you made a post on the Bug Reports category.

According to the Obsidian FAQ this is the correct action. Hopefully the team can get things fixed and working for you.

Hello, I have the same problem as len3, but on Windows10. I can also say with some certainty that it has nothing to do with the ‘live preview’ of the editor, because as a newbie I use a practice vault to try out plugins and here the linking also works like in the conventional editor with drag and drop while holding down the Ctrl key.
Since the update v0.13.23 has been automatically applied to all vaults on the computer, I suspect that it is rather due to some settings, but I can not find them.
len3, if in the meantime you have found a solution, or the cause, I would be very interested in it, because I have been searching in vain for days.
Also, I apologize; My English is so bad that I have to make do with an online translation. I hope I could still make myself understood.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.