Disable spell checking completely

I disabled spell checking in the preferences but it still pops up e. g. when renaming a file or relabeling something in Excalidraw. How do I disable spell checking for Obsidian completely if at all possible?

What operating system are you on? I don’t recall ever seeing spellcheck when renaming files on Mac or iOS.

Does this still happen after you turn on Settings > Community Plugins > Restricted Mode and restart Obsidian?

I’ve seen this behaviour on macOS and Windows 10. The problem persists in restricted mode.

How are you renaming files?

I right click on the file and choose rename from the context menu. I then edit the file name in the left sidebar.

OK, I do see spellcheck’s red squiggles there. I guess I stopped noticing them at some point.

I’ve filed a bug report about the inconsistent behavior.