Disable "Search options" popup help?

Using Obsidian 1.4.9

Wondering if anyone knows of a way to disable the popup below that appears whenever you focus the search field?

I’m familiar enough with these modifiers, so now they just get in the way. Also, since “path:” is highlighted by default, what often happens is I hit ENTER to actuate a search, but instead, Obsidian inserts an unwanted path: into my search field.

I read Search - Obsidian Help but didn’t find any solutions there.


Disable the respective option by clicking on the search settings button on the top right corner:

Screenshot 2023-09-09 225335

I only see that when the search field is empty. When I type anything it goes away. Does that not happen for you?

“Explain search terms” does something else.

The popup appears whenever the field is empty OR a space is typed. It also appears when you activate your “Search” hotkey if there is already some text in the search field. I guess having it there when the field is 100% empty is fine, but I definitely don’t want it popping up every time I press the spacebar or hit my Find hotkey.

1 Like

This looks like the selector with a display: none to hide it:

.suggestion-container.mod-search-suggestion {
    display: none;

but that’s going to get rid of the History section that shows up under the Search options as well. I guess if you don’t use History and know the options, you could try that. You can refer to your first screenshot if you forget them. :laughing:

Ah, I didn’t test with a space. (I’ve done searches with spaces before but tune out the popup unless I need it.)

Correct you are … :blush:

That’s a creative idea but sadly, all it does it hide the box, the functionality is still there, meaning if you press ENTER you will still get the word path: inserted into your search query.

We need an option to disable this popup entirely.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.