Data loss!


I had a length Daily Notes page written up today on my Mac, and when I opened Obsidian on my iPad, it showed me an empty Daily Notes page. “No problem,” I thought - it probably just created a new file because the one on my Mac probably didn’t sync over yet. And indeed, there were two files for that day’s notes on my Mac. However, even the original file had been overwritten with the blank one, so both notes were blank.

Now I don’t know how to get my lost data back.

I’m using iCloud sync. Please help urgently! Is there a way to go back to a previous version of a file?

1 Like

Tried this?



Angel - you are a lifesaver. THANK YOU!

Glad you got it back. Make sure you try to figure out what caused this, too. Are you using Windows at all?

This has been happening to me for a few weeks and, recently, it is replicable every day.

I used to use the Daily Note core plugin and, on suggestion from elsewhere on this discussion board, turned that off and went to Periodic Notes instead. That solved the problem until, like I said, recently.

If I initiate a daily (through Periodic Notes) on my (Windows) computer, subsequently opening the note on either my iPad or iPhone will generate a new, blank note from my template and erase what I had previously typed. I can do a File Recovery but only when back on the original computer.

The only way that this doesn’t happen is if I initiate the daily on an iOS device. The computer never overwrites from mobile.

The frustrating thing is that this happens ~50% of the time on iPhone but nearly 100% of the time (I just replicated before this post) on iPad.

I don’t have a lot of plugins operating and have gone through each one trying to figure out the problem but haven’t been able to do it.

1 Like

As a newbie who has also suffered lost daily notes I am finding this forum thread helpful. So far I have discovered the importance of File recovery - hattip to Angel. The possibility of rediscovery of the initial file by going back to the originating device - thanks to terryjbenzie. Your question about Windows use is intriguing ryanjamurphy - care to expand?

1 Like

It seems that users regularly have trouble using iCloud Drive with Windows machines. There’s another thread about this where that is the common theme: File Loss with iCloud/iPad/Mac Sync

Unfortunately I don’t think this is an Obsidian problem, but we are continuing to collect reports from users in order to understand exactly what’s going on. So, if you see issues again, please try to remember exactly what happened and report back.


I use Obsidian sync and have never used iCloud to sync notes.

For now, I am migrating to longer notes that encompass several days, something that I’ve been considering before.

How are you syncing, then?

Edit: sorry, Obsidian Sync. Missed that somehow.

You’re describing a different issue than the OP. Obsidian Sync needs Obsidian to be open on any device in order to work. So that creates the opportunity for a race condition: if you make two changes on two different devices without Obsidian Sync running on both at the time, it creates a conflict, and most recent wins.

To test this the last two days, I was on my iPad sitting directly in front of my computer. When I pushed “Open Today” I saw the note generated on the device and, about five seconds later, delete on my monitor in front of me.

The OP situation sounds precisely like mine, except they sync through iCloud and I use Obsidian sync.

Where’s your vault stored on your devices? Is it possible that when you created your vault on iOS, you selected “Store in iCloud,” and then set up Obsidian Sync in that vault?

Or, is it possible that the vault is saved inside a directory synced with another service on any of your devices?

There is a race condition happening here. I highlight doubt the cause is Obsidian Sync acting alone.

Hi Ryan… From described, seems the Sync direction (push/Pull) is not set up for their preferred Workflow? As in they start the Note on Desktop/Windows/Obsidian, then want to re-open it on a Mac /IOS device. So, seems like Obsidian needs to be told to Push data to the other Devices AND other Devices need to be told to Pull data from the Desktop/Windows device, yes?

I’m not sure I follow exactly, but if I understand you right, this is complicated by iOS. The iPhone and iPad operating system does not allow for robust background sync. So, yes, conflicts can occur when adding new data to Obsidian on an iPhone before opening the app —e.g., if you launch a URL scheme to add something to your daily note.

My vault is stored locally on each device. I didn’t install Obsidian on either until I had purchased Obsidian Sync and set it up.

I think that I’m giving up. I have gotten to where if I start a Daily on one iOS device then open it on the other before I view it on my computer, it…usually works. However, this morning, I started the note on my iPad, did about an hour worth of work on my computer and, the moment I clicked on “open Daily” on my iPhone, I watched it disappear and be overridden with a blank template.

Sure, I recovered the files but if I am out for the day, I can’t go back to my computer to do so.

Sorry about all the trouble. There’s definitely something odd going on—many people successfully use Sync on iOS without issue.

How are you doing this? Are you using the Open Daily Note command from within the app?

It happens when I hit the “Open today” button in the sidebar.

Sync works, simply not all the time. I’m sure that some people have better success with it. Some, presumably, worse. I do appreciate you responding - I sent a note into the company and never heard back.

I initially installed and used Obsidian for a zettelkasten-style of linked notes system and it worked perfectly for that. It’s when I tried to use it for daily notes and across devices that it broke down. I think I was trying to use it for something it’s not yet suited for.

If I wanted to declare bankruptcy on all daily notes, etc, would the best way be to simply move my local files to another location on my hard drive for safe keeping then initiate a new vault inside the app? My idea is to simply use it for linking ideas and to not use it on iOS - that should let me use it without problem.

Hmm. Hold on. Is the only Sync trouble you’re having happening when you create a new daily note?

Yes, and only on iOS BUT this happens regardless of a note has already been generated on a computer. (i.e. If I pick up my iPad at the end of the day and press Daily, it overwrites). What are you thinking here?

I think that I may have found the problem and a tenable solution though. It appears that the plug-ins for Periodic Notes and/or Daily Notes was causing this issue. I continue to use Periodic Notes on both computers but have disabled it on both my iPhone and iPad and the problem appears to have stopped. This morning I turned it back on in my iPad and the device overwrote an existing note.

I don’t think this is an issue with Sync at all. As you’ve discovered, some kind of plugin interaction is causing your notes to be overwritten. The data is probably synced successfully, but something happens when you hit “Open Daily Note.”

Some ideas:

  • You had multiple Daily Note plugins enabled and they conflicted somehow
  • You had configured the Periodic Notes plugin (or the Daily Notes plugin) differently on the different devices. E.G., one was opening 20220330, another was using 2022-03-30z
  • Some kind of bug (have you updated community regularly?)

There could be other options.

Either way, though, this isn’t a sync issue!

I’ve tried everything you suggested (i.e. going through to confirm that configuration was correct and updating community) previously and, again, just now but things look correct.

I posted this question elsewhere and was referred to a ‘paid community’ that, reportedly, has figured out this program but I’m not going to shell out the kind of cash required to figure out.

Simply removing the Periodic plugin on iOS appears to have solved the problem so I’m going to assume the bug is in that (and, if not, it solves the problem anyway).

1 Like