Cursor ends up before the letter on android Samsung keyboard

Steps to reproduce

Adding a formatting command (like a bullet "- ") places the cursor before the next letter you type like “|t” so when you start typing you are now typing before the first letter. “nt”.

This behavior only occurs with the Samsung default keyboard. Gboard seems to work as expected.

Did you follow the troubleshooting guide? [Y/N] Y

New vault, no plugins

Expected result

Expected the cursor to be after the letter typed.


Operating system: android 14 (samsung SM-X700)
Obsidian version: 1.5.9 (130)
API version: v1.5.9
Login status: logged in
Catalyst license: supporter
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

This did not happen in Obsidian 1.5.8, nor were there any updates to Android between 1.5.8 and 1.5.9.

The uploaded zip file contains a short recording of the behavior. (744.5 KB)


Does this only happen in lists?
What the Samsung keyboard version?
Does it happen in source mode?

1 Like

So far, pretty much any formatting command is a problem, I haven’t found one that worked yet but I haven’t tried them all.

And in source mode and live preview.

Latest version of Samsung keyboard:

1 Like

Here is some more information on this bug. Turning off the ‘predictive text’ option in the Samsung Keyboard settings eliminates the behavior.

I’m on Samsung keyboard and see this behaviour.
Turning predictive text off does NOT fix the problem for me.
I use both swiping and normal typing, and the bug is there with both methods.
Happy to carry out further tests if anyone can suggest a strategy.

Obsidian 1.5.11 (133)
Android 14


Obsidian version 1.5.11
Andriod: 14

I experience the same issue not only on Samsung Keyboard but also on Gboard.

Seeing that this issue does not occur in other apps, it seems that it is not a Samsung Keyboard issue, but an Obsidian editor issue.

This issue frequently occurs in lists. (2.4 MB)


Does it happen if you forde google spell check not samsung spellcheck?

I am not talking about the keyboard.


For what it is worth, I am also experiencing the exact same issue. I’ve noticed that this does NOT apply to typing numbers for whatever reason.

Also on Android 14 on Obsidian Version 1.5.11

1 Like

Experiencing the same issue with version 1.5.11 on SM-X510, Android 14. This was not present in previous version and disabling Predictive Text in the Samsung keyboard settings seems to fix it.

Having the same issue, Samsung Galaxy s23 with the latest Android updates and Obsidian Version 1.5.11.

For me the issue only manifests when I’m typing in lists and sometimes with bold/italic text. Disabling spell checker and using google or samsung spell checker did fix the issue.

1 Like

I am experiencing this same issue on multiple Android devices following the latest Obsidian update:

  • Samsung Galaxy Tab S9 Ultra, Android 14, One UI 6.0, Obsidian 1.5.11

  • Samsung Galaxy S24 Ultra, Android 14, One UI 6.1, Obsidian 1.5.11

When I am typing in a list in a note, after typing the first letter of a word, the cursor will jump back in front of the first character of the word.


Can confirm this behaviour regarding lists on Pixel 3 XL (LineageOS 21 / Android 14).

1 Like

Same thing for me. Samsung phone. But it seems to happen in template notes. Started right after the update that happened this morning.

1 Like
  • Obsidian 1.5.11
  • Android 14 (Pixel 8)
  • Gboard (Japanese Input)

I experience the same issue. Disabling spell checking on Android doesn’t fix it.

  • Obsidian 1.5.11 (133)
  • Samsung S 22 Ultra
  • Android 14
  • Samsung keyboard

Turning predictive text off fix the problem for me.

Same problem here:

  • Obsidian 1.5.11 (android)
  • Samsung tab S9 FE
  • Android 14 (One UI 6.0)
  • Samsung keyboard

Turning off predictived text fix the problem.

I am also encountering the same issue. Note that this issue occurs for both list lines as well as any lines that start with a space. For example, on a new line, trying to type:

- Test

will result in:

  • estT

And, on a new line, trying to type:


will result in:


System details:

  • Obsidian 1.5.11 (Android)
  • Samsung Galaxy S20 FE 5G (Canada)
  • Android 13 (Samsung One UI 5.1)
  • Samsung Keyboard (with “Predictive text” enabled in the Settings for Samsung Keyboard)


  • Option A:
    • Turn off “Predictive text” in the Settings for Samsung Keyboard.
  • Option B:
    • Use a different software keyboard (like Gboard).

I’ve tried using Gboard and turned off predictive text settings, but the problem persists. In Korean. (3.2 MB)


I can confirm this Bug. For me it occurred after I updated to 1.5.11.

  • Samsung Galaxy S21 FE
  • Android 14

For me it’s not an option for me to disable predictive text for just one app so my workaround was to downgrade to 1.5.8 which works great!


Hello. obsidian 1.5.11 on Ubuntu 22.04 is also same problem in Korean…