Creating a note/folder with a title that starts with '.' displays differently in different OSs

On macOS, I created a folder with a title .inbox to keep it sorted at the top. I could interact with that folder normally inside the Obsidian application.

When I tried to access that Vault from a Windows version of Obsidian, that folder was hidden from view. I checked the underlying file system and it did exist, but the Windows app wouldn’t see it.

I get that . folders are supposed to be hidden on *nix systems, but why can I see it on macOS and not Windows?

I think that’s also a setting in Finder/MacOSX to show and hide .extensions.
_ is your friend.

. folders are hidden from the file explorer because of the convention. I understand it’s visible in the Windows file explorer, but things like .git and .sync have caused issues with the file explorer, and so we started hiding them starting 0.5.0.

I wanted _ to be my friend, but then backlinks are italicized. So maybe that’s the bug report. Italicization (or bolding) should take effect until the matching token is typed.

Safer to go with a ! or number 0 as a leading character I guess.