Constant 40% CPU on M1 despite safe mode and no css

Hello friends,
Obsidian uses constant 40% CPU on my new M1 Mac, despite safe mode ON and no CSS, even when an empty note is opened and nothing else.
It must be something in my vault, because in a Vanilla Vault I have 0% CPU.
Can anybody read a dev console perfomance snapshot and help me figure out what the issue is?
I unfortunately don’t speak code and have no idea.
Thank you very much in advance to the kind soul who hopefully will take a look into this! :pray:

[had to zip it to upload it here]
40pct CPU safe mode no (137.6 KB)

I feel like something in your indexeddb might have gotten corrupted - Try going to devtools - Application tab - IndexedDB in the sidebar, expand - delete all -cache items, and the rebooting the app.


Thank you Licat for the hint.

I deleted all -cache items and restarted Obsidian.
At first the 40% CPU remained. Additionally it started to re-index the whole vault upon every startup.
I tried to delete the -cache files again. There was only 1 now, and that one wouldn’t delete.
I left it till evening and restarted when the 1.1.7 update dropped.
I didn’t really have much time to investigate, but before, it seemed that CPU usage did go down to 0-3%, with restricted mode on and all snippets disabled!

I will monitor it in the course of tomorrow.

One question about the -cache: I also see 4 cache files for dataview, and 4 for omnisearch (which I uninstalled).
Is it safe to delete all those as well as a precaution?

Licat’s suggestion fixed it. I think it took a bit to rebuilt the cache fully.
Later I also deleted the dataview and omnisearch caches, just in case. Didn’t have any negative consequences (but I made sure to turn in restricted mode first and reboot obsidian).

1 Like