Configured macOS custom keyboard shortcuts for Obsidian don't function in editor but appear activated in menu UI

Steps to reproduce

On macOS (running latest version):

  1. In System Settings, click Keyboard from the sidebar and then select the Keyboard shortcuts button.
  2. From the left sidebar, select App Shortcuts.
  3. Click the plus button to add Obsidian and create a custom keyboard shortcut for a menu item like Strikethrough which does not have a keyboard shortcut by default (ex. Command + Shift + S).
  4. In Obsidian, highlight some text that does not have strikethrough formatting and use the keyboard shortcut. Note in the editor the text does not become highlighted.
  5. In the menubar for Obsidian, click ‘Format’ and note that ‘Strikethrough’ has a checkmark next to it as if it is in fact formatted for strikethrough.
  6. Trigger keyboard shortcut again, similarly noting in menubar under ‘Format’ that checkbox indicating Strikethrough formatting is now no longer shown but that editor format has still not changed.
  7. Manually select ‘Strikethrough’ from menubar menu and note that strikethrough formatting does correctly apply to the selected text.
  8. Attempt using pre-configured / built-in keyboard shortcuts and note these function as expected in editor

Did you follow the troubleshooting guide? Y

Expected result

Text is formatted as desired given configured macOS keyboard shortcut for Obsidian

Actual result

No formatting is applied, but checkbox adjacent to applicable formatting is added/removed as if it did format correctly


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.5.0: Mon Apr 24 20:52:24 PDT 2023; root:xnu-8796.121.2~5/RELEASE_ARM64_T6000 22.5.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

When keyboard shortcut is configured:

When keyboard shortcut used to format text, not checkmark in menu UI:

The obsidian hotkey should be configured via the internal obsidian settings>hotkeys. We do not support any other way. Open a feature request for that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.