Changing text font size doesn't change the headers font size

Steps to reproduce

  1. Create the following markdown
# H1
## H2
### H3
#### H4
##### H5
###### H6
Normal text
  1. Go to Options > Appearance > Font > Font size and modify it to maximum (30px)

Did you follow the troubleshooting guide? [Y/N]


Expected result

The headers size are updated proportionally

Actual result

Only normal text size changed and headers didn’t (see screenshot below)


	Obsidian version: v1.4.1
	Installer version: v1.3.5
	Operating system: Windows 10 Pro 10.0.22621
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: none
	Snippets enabled: 2
	Restricted mode: off
	Plugins installed: 59
	Plugins enabled: 34
		1: Linter v1.17.0
		2: Recent Files v1.3.7
		3: Smart Rename v1.0.0
		4: Templater v1.16.0
		5: Shortcuts extender v2.2.0
		6: Custom Attachment Location v0.0.9
		7: Folder Note Core v1.3.6-unofficial
		8: AidenLx's Folder Note v0.16.5
		9: Advanced URI v1.36.4
		10: Frontmatter Links v1.2.7
		11: Copy Image and URL context menu v1.5.0
		12: Advanced Tables v0.19.1
		13: Filename Heading Sync v1.9.0
		14: Force note view mode v1.2.0
		15: Plaintext v0.3.0
		16: Plugin Groups v2.1.0
		17: Boost Link Suggestions v1.0.2
		18: Another Quick Switcher v8.14.0
		19: Quick Switcher++ v3.3.4
		20: Bulk Rename v0.5.2
		21: Obsidian Link Converter v0.1.5-unofficial
		22: Front Matter Title v3.5.2
		23: Hot Reload v0.1.10
		24: Code Editor Shortcuts v1.14.0
		25: Buttons v0.4.19
		26: Commander v0.5.0
		27: Copy as HTML v1.1.3
		28: Obsidian markdown export v1.0.10
		29: CustomJS v1.0.13
		30: Telegram Sync v1.8.1
		31: Consistent attachments and links v1.0.8-unofficial
		32: QuickAdd v1.2.1
		33: Obsidian Git v2.20.6
		34: Dataview v0.5.56

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information



Currently to solve this issue I have to use the custom css

body {
    --h1-size: calc(1.802 * var(--font-text-size));
    --h2-size: calc(1.602 * var(--font-text-size));
    --h3-size: calc(1.424 * var(--font-text-size));
    --h4-size: calc(1.266 * var(--font-text-size));
    --h5-size: calc(1.125 * var(--font-text-size));
    --h6-size: var(--font-text-size);

but in my opinion, that change should be made in Obsidian source code instead.


+1 this is also happening to me, very strange when the headers are smaller than the content text. Mac and Linux 1.3.5 installer, 1.3.7

1 Like


Thank you for including the CSS.

will be fixed 1.4.3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.