Change paragraph size both editor and reading mode


Using a widescreen (or not really that wide) makes the text look awful. I added a CSS snippet to make it more readable but it only affects reading mode. In reading mode looks fantastic but in editing mode still looks awful. I tried with both the options of limit “Readable line length” on and off.

/* Adjust the width of paragraphs in the editor mode */
.markdown-preview-view p, 
.CodeMirror pre, 
.CodeMirror-wrap pre {
  max-width: 800px !important; /* Change this value to adjust the maximum width of paragraphs */
  margin-left: auto;
  margin-right: auto;

How do i fix this?

What theme do you use?

Minimal. does that affect?

I’m ussing this snippet. Check if it works for you (I haven’t any theme installed)

body {
--file-line-width: 800px !important;
1 Like

Depending on the theme you use, there may be options in their settings or specific CSS that’s needed (the CSS Tanto_Monta posted above is usually fine).

Using the Minimal theme, it’s easy! → Install the Minimal Theme Settings (if you haven’t yet) and change the “Normal line width” here (mine is set to 42). This will change editing and reading modes with no CSS necessary.

1 Like

worked like a charm!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.