Reading mode blank line paragraph

This is how HTML works. When you switch to reading view, the white space is collapsed.

CSS is the answer here, but as you are using the Minimal theme, you have some typography options in Minimal Theme Settings (a plugin). See here:

In Style Settings (also a plugin), Minimal has an option to change the paragraph spacing under Minimal > Text → Paragraph spacing.

If playing with these settings doesn’t produce the results you want, then you will need to use a CSS snippet(s).