Canvas: Error when exporting canvas as image

Steps to reproduce

  1. Create a new canvas.
  2. Export canvas as image,
  3. Select option “Full canvas”
  4. Save image

Expected result

The rendered image should represent the full canvas

Actual result

The rendered image looks bugged. It doesn’t represent the full canvas. it only renders a small part of it


  • Operating system:
  • Debug info:

    Obsidian version: v1.1.9
    Installer version: v1.1.8
    Operating system: #1 SMP PREEMPT Mon Dec 19 13:16:33 UTC 2022 5.15.84-1-MANJARO
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Atom v0.0.0
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 9
    Plugins enabled: 8
    1: Editor Syntax Highlight v0.1.3
    2: Dynamic Table of Contents v0.0.27
    3: Homepage v2.4.1
    4: Advanced Tables v0.18.0
    5: Dataview v0.5.47
    6: Ozan’s Image in Editor Plugin v2.1.5
    7: Templater v1.16.0
    8: Calendar v1.5.10

Additional information

View inside obsidian:

Exported canvas result:

post a screen recording of this happening in the sandbox vault

For v1.1.9, perhaps installer v1.1.9 as well:

The Installer has been updated to use Electron v21 (requires downloading the latest Installer from ).

Same here. The export as image does not work. I either get broken images or files that can’t even open in macos Preview app.

Attached: screenshot of the canvas, screenshot of the exported image.

Obsidian version: v1.1.12
Installer version: v1.1.9
Operating system: Darwin Kernel Version 22.2.0: Fri Nov 11 02:08:47 PST 2022; root:xnu-8792.61.2~4/RELEASE_X86_64 22.2.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Minimal v6.2.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 40
Plugins enabled: 40
1: Readwise Official v2.0.1
2: Advanced Tables v0.18.1
3: QuickAdd v0.8.0
4: Templater v1.16.0
5: Dataview v0.5.55
6: Kanban v1.5.1
7: Paste URL into selection v1.7.0
8: Highlightr v1.2.2
9: Calendar v1.5.10
10: Periodic Notes v0.0.17
11: Media Extended v2.11.1
12: Smart Typography v1.0.18
13: Homepage v2.7.3
14: Customizable Page Header and Title Bar v4.6.2
15: Annotator v0.2.10
16: Matter v1.1.4
17: Checklist v2.2.12
18: Pandoc Plugin v0.4.1
19: Footnote Shortcut v0.0.9
20: Enhancing Mindmap v0.2.4
21: Spaced Repetition v1.9.4
22: Note Refactor v1.7.1
23: Shortcut Launcher v1.0.1
24: Advanced URI v1.31.2
25: Advanced Slides v1.19.0
26: Projects v1.11.5
27: Recent Files v1.3.5
28: Excalidraw v1.8.12
29: Status Bar Pomodoro Timer v0.1.14
30: Dictionary v2.22.0
31: Natural Language Dates v0.6.1
32: Better Word Count v0.9.4
33: Book Search v0.5.9
34: Obsidian42 - Strange New Worlds v1.1.2
35: Emoji Shortcodes v2.2.0
36: Multi-Column Markdown v0.7.7
37: Wordy v1.0.0
38: WakaTime v1.0.0
39: Heatmap Calendar v0.5.4
40: Sort & Permute lines v0.6.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

  1. Does it happen in restricted mode and default theme?
  2. what are you computer specs exactly?

some changes will be made in 1.1.14, let me know if it works

On the latest insider build, I’m getting stuck at “rendering tiles” when exporting a full simple canvas (text only, not many cards). Stop button is also non-functional (have to quit to regain control). I’m on an M2 Mac with 16GB of memory.

this sounds like a different problem. Open a new bug report and post ascreen recording of it happening in the sandbox vault.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.