Canvas: Error when exporting canvas as image (reopening a graveyarded topic!)

Still having the same issues as described in this graveyarded thread

Debugging infos:

Obsidian version: v1.5.3
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:54:10 PST 2023; root:xnu-10002.61.3~2/RELEASE_X86_64 23.2.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: adapt to system
Community theme: AnuPpuccin v1.3.1
Snippets enabled: 4
Restricted mode: off
Plugins installed: 56
Plugins enabled: 54
1: Recent Files v1.3.10
2: Templater v2.1.3
3: Checklist v2.2.13
4: Advanced Tables v0.21.0
5: Advanced URI v1.40.0
6: Annotator v0.2.11
7: Better Word Count v0.10.1
8: Book Search v0.5.11
9: Buttons v0.5.0
10: Calendar v1.5.10
11: Customizable Page Header and Title Bar v4.6.2
12: D2 v1.1.4
13: Dataview v0.5.64
14: Dictionary v2.22.0
15: Emoji Shortcodes v2.2.0
16: Excalidraw v2.0.20
17: Footnote Shortcut v0.1.3
18: Heatmap Calendar v0.6.0
19: Highlightr v1.2.2
20: Homepage v3.7.0
21: Image Caption v0.0.15.alpha
22: Kanban v1.5.3
23: Media Extended v2.11.1
24: Multi-Column Markdown v0.9.1
25: Natural Language Dates v0.6.2
26: Note Refactor v1.8.2
27: Charts v3.9.0
28: Strange New Worlds (SNW) v1.2.5
29: Omnisearch v1.21.1
30: Pandoc Plugin v0.4.1
31: Paste URL into selection v1.7.0
32: Periodic Notes v0.0.17
33: PlantUML v1.7.0
34: Plugin Update Tracker v1.5.2
35: Projects v1.17.1
36: QuickAdd v1.6.1
37: Readwise Official v2.0.1
38: Shortcut Launcher v1.0.1
39: Smart Typography v1.0.18
40: Sort & Permute lines v0.7.0
41: Spaced Repetition v1.11.1
42: Status Bar Pomodoro Timer v0.1.14
43: Style Settings v1.0.7
44: Text Extractor v0.5.1
45: Text Generator v0.6.13
46: WakaTime v1.0.0
47: Wordy v1.3.1
48: Link Embed v2.0.12
49: Novel word count v3.3.3
50: Numerals v1.2.0
51: Google Calendar v1.10.14
52: Smart Connections v2.0.111
53: WordNet Dictionary v2.0.3
54: Zotero Integration v3.1.7

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Please, download and reinstall obsidian and post a screen recording of this happening in the sandbox vault

It works in the Sandbox.

ok, open your vault, use the default theme, enable safe mode, restart obsidian.

Take a screen recording of the problem happening.

default theme ON
restricted mode ON
==> Works

theme back to AnupPuccin
restricted mode ON
==> Works

so I guess one plug-in is messing things up…
I can try to disable them one by one (if there is no risk of losing my settings)

There is a Divide and conquer plugin which can aid you to locate the “faulty” plugin. And disabling (not uninstalling) a plugin, shouldn’t affect your settings.