Can't update plugin

Steps to reproduce

  1. Go to list of installed community plugins
  2. Locate “Tasks” version 1.3.0 and click to view info
  3. Click “Update” to update to latest version (currently 1.4.1). Obsidian notifies that the new version has been installed but 1.3.0 is still installed.

In screen recording below, notice that installed version stays the same even though update is clicked.
GIF 11.11.2021 9.43.57

Expected result

Plugin updated to latest version (1.4.1)

Actual result

Plugin is not updated, still 1.3.0


  • Operating system: Windows 10
  • Obsidian version: 0.12.16 / Installer 0.8.12

Additional information

Steps I’ve tried to fix it that were unsuccessful:

  1. Uninstalled plugin, made sure it was completely deleted from .obsidian-folder and restarted computer. Then installed the plugin again but 1.3.0 gets installed and error continues.
  2. Create a completely new Vault. Installed Tasks there as the only plugin. Version 1.3.0 got installed, not the latest 1.4.1. Same error when updating.

Same error has been reported by others as well: Can't upgrade to or install version 1.4.1 · Issue #389 · schemar/obsidian-tasks · GitHub

Thanks! I am wondering whether there is something I need to do here? I cannot reproduce the issue and it occurs only for some users.

@WhiteNoise have you had a similar issue with other plugins?

Let me know if I can do anything to support.

Look at your obsidian version and look at this

You have a very old installer too. Download and reinstall obsidian.

1 Like

Thank you, downloading the installer anew from and installing solved the problem.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.