Can't navigate to Network drive for Vault on PopOS

Hi! I like to keep my vault on my NAS so that I can access it securely between machines. Unfortunately when I goto open vault on PopOs it will not let me search for a network drive. Is there a solution around this, maybe i can manually set the location of the default vault somewhere?

1 Like

Should I repost this under bugs?

I’m willing to bet there aren’t too many here on PopOS using a NAS.
The one time I tried Pop, I recall a fair amount of grief over mounting drives. I’m willing to bet this is more of a network thing than something with Obsidian.
I realize that helps not at all, but it’s my two cents’ worth. Good luck!

Thanks for the reply Eris! I’m not familiar with Linux at all but I am able to access the NAS through the file viewer on Pop OS but as soon as Obsidian opens file viewer to navigate to the vault the network drive won’t show up. I can update with screenshots later when I get home.

Did you use the AppImage or install through Snap?
I only ask because Snap is error-prone, the AppImage has been waaay more stable (for me, at least).
I can confirm network drives are accessible on Windows, so I’m positive it’s possible. They’re just… tricky on -nix systems.
I started using Git because it is basically cross-platform. For what it’s worth, I use Windows, Linux Mint, and Manjaro regularly. Pop is gorgeous, but too finicky for me.

I installed it through snap which was the little app manager, maybe I will try installing with AppImage if I can figure it out. I also am able to access on my Windows10 side, I just set up my own self hosted Git with Gitea last night so I have the benefit of Git but local as well to be accessible between apps and mobile in the future.

Just cant get to the network vault on Pop yet, I almost tried Manjaro but was reading some negative things and everyone has their flavor it’s difficult.

Try the AppImage, it’s dead simple. Download the file, right click and find the checkbox to ‘make executable’ in permissions - that’s it. There’s also a way to add it to the menus that isn’t too tough.
I can’t help much more with the network thing, unfortunately. I unhooked my -nix laptops from them. I’ll try if you get some more details but I’m hoping someone else with first-hand experience chimes in.

Just as a quick update, I installed using the AppImage last night and still had the same issue, couldn’t get the network drive to show up once I hit select vault :frowning:

Unfortunate. If I get a chance, I’ll hook up a NAS and give it a go just to see what Manjaro looks like. No guarantees when I’ll be able to, though.
I still think you have an underlying issue with the way the network drive is being ‘mounted’ on the OS.
Still hoping someone else has more first-hand experience with NAS setups on this type of system.

1 Like

I use vaults which are stored on a NAS on different Linux clients without any problems. However, I share the directory using the NFS protocol and not - say - SMB.

I install obsidian through flatpak. By default flatpak app cannot access any outside file systems like NFS. However, I can override that with the following flatpak command:

  1. First identify the obsidian app id:
    flatpak list

  2. Then override restriction to the NFS filesystem. Note: have to use sudo from the account in which you launch obsidian.
    sudo flatpak override --filesystem=/nfs_mount

  3. Restart obsidian

Generally you don’t even need sudo for adding your own overrides, instead you can use the --user option:

flatpak override --user --filesystem=/nfs_mount md.obsidian.Obsidian

There’s also Flatseal, which is a GUI for viewing permissions and setting your own filesystem mounts, in addition to the ones already set: