Can't install Obsidian


I am having trouble installing Obsidian on my win 10 computer.
All my drivers are fully updated, tried disabling firewall, ran as administrator and startup pc in safe mode. But it’s still giving me the error 'Obsidian is running, click OK to close it…

After clicking OK it just gets stuck in a loop. I have also looked around the forum and found people with somewhat similar problems, but they all solved their problems via the things I tried mentioned above. I have also never had obsidian installed before so I’m not sure about any steps I could take.

I’ll just copy/paste some of these questions from another one of those threads, if you can think of any additional info you can give.

There is a game company called Obsidian. And I think some music software too. Do you have anything else named Obsidian installed? (I highly doubt this is it, but worth asking.)

I searched through all my folders for anything named ‘obsidian’ but there is nothing.

there is also no process named Obsidian in my task manager (except for when I try to install it)
I tried placing it in D/: drive and C:/ drive but no difference made.

as for anti-virus/firewall, I have disabled both but still got the same error.

Where did you get your copy of Obsidian from?

Sorry for the late reply,

I downloaded it from the website (Download - Obsidian)

tried the ‘download for windows’ one and the windows standard 64-bit one

I have also tried downloading and installing older versions, but still the same issue

Maybe create a new Windows user and try to install there. If it works there I’m not sure what that tells us or how to proceed from there, but it would be information of some kind.

1 Like

Should check which processes and programs are actually running

They did, a few posts up.

I thought they only looked for processes called Obsidian

I will attempt to create a new user and install it from there! @Dor Which other processes and programs should I check for when trying to run the installer?

I don’t think I’ve seen anyone else with this installer problem, so it’s pure guesswork what might be going on (unless anyone knows exactly how the installer works and what it checks and reports). So checking all applications and processes is a simple extension of the logic used above. If the installer thinks Obsidian is already running, it’s either glitching or the check is misidentifying a process as Obsidian; that process wouldn’t need to be called Obsidian - the installer might just say Obsidian is already running because Obsidian is what it’s trying to install.

You might need to go through the registry to see if there’s anything left behind from failed installations. I assume you have no problem installing other programs; if you do, then it would be worth doing a thorough system check for viruses etc. Already running errors are known with other installers, so worth checking for suggested solutions for them too - eg 5 Solutions to "Avast Setup Is Already Running" Error - MiniTool Partition Wizard

1 Like

@CawlinTeffid Trying to install from a different user worked! It’s installed now and I can access it from my main user account. :slight_smile: Thanks for the help!

1 Like

Oh wow, I just meant it as a testing thing but I’m glad it got things working for you!

I’d follow up with Dor’s suggestions too just to check for anything wrong in your system that you should know about.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.