Can't delete folders using Obsidian sync?

It seems like I can’t delete folders while using Obsidian Sync.

Steps to reproduce

  • Use Obsidian Sync
  • Create a folder
  • Have the folder synced in multiple devices
  • Delete the folder on one device
  • Wait a few seconds. The folder will reappear

Expected result

  • I expect the folder to be deleted on all my devices

Actual result

  • The folder reappears


  • Operating system: MacOS and iPad
  • Obsidian version: 0.12.15

Additional information

  • I’ve already tried deleting the folder on multiple devices
  • I also tried renaming the folder, now I just have 2 folders
  • The folder is empty

Is this vault synced only used obsidian sync or is there something else operating on this vault?

Can you attach the sync logs? thanks

Welp. I tried to reproduce it (and I swear it could be reproduced when I wrote this bug report), but it looks like it’s working now? I waited a full 10 minutes and double checked on a different device, and the folder has been deleted on both.

To answer your question though, it was synced only using Obsidian Sync.

Thanks for your response!

I’ve actually been having the same problem. For me its both files and folders which reappear. I have my vault synced on mac, an iPad and an iPhone. The Vault is also stored on a Microsoft Onedrive folder. Though the issues occurs regardless of whether the Onedrive App is active or not.

If I delete a folder on the mac, then when opening the app on an iDevice the folder will sometimes but not always reappear once syncing has finished.
If I delete the file or folder on the iDevice, the file/folder will always stay.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.