Can't change slides in slides core plugin without clicking first

When I open a note in slides there is no way to change between slides.

The navigation buttons don’t appear and the keyboard arrows and space bar don’t work either.

I’ve separated the slides with ---

I’m using MacOS 10.15.7 and Obsidian version 1.4.12


Moved to help for not following the bug report template.

If you post in help, you see this template. Have you tried these debugging/troubleshooting steps yet?

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

Make sure to redownload Obsidian to get the latest installer. And update any plugins and themes. Test in the Sandbox vault, etc. etc.

And moved back to Bugs because I can reproduce.

It looks like the keyboard focus remains in the note, instead of focusing on the presentation.

If you click on the presentation, then the navigation keys work.

But if you hit space bar, in this screen recording in the Sandbox vault, you can see the spaces get typed into the note, instead of navigating the presentation.


Obsidian version: v1.4.9
Installer version: v1.4.5
Operating system: Darwin Kernel Version 21.6.0: Mon Dec 19 20:43:09 PST 2022; root:xnu-8020.240.18~2/RELEASE_ARM64_T6000 21.6.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Thanks. I am able to prevent spaces from inserting into the file by clicking on the presentation but this still doesn’t enable me to change slide. Arrow keys not working either. Could I be doing anything else wrong?

No need.

I was typing the ` before and after the —

I had tried just — before but now works with the click on the presentation.

Apologies - I’m new to Obsidian


Don’t mark it as solution; the topic will close automatically. I’ll open it back up. The presentation should receive focus properly. :slight_smile:

I experience same bug with navigation in MacOS 14.2.1 and Obsidian 1.4.13, arrows and space bar don’t work

not Mac specific

Use case or problem

When I start the presentation I cannot use the keys to navigate to the next slide. First, I have to use the mouse to click on the presentation to give it focus.

Proposed solution

Presentation automatically gets focus when it is started.


Yes this is so basic but so critical. Obsidian is very suited to people who like to build keyboard driven workflows. The need to click on the presentation is very annoying in this context.

Agree with proposed solution. The presentation should have keyboard focus when launched.

1 Like

I didn’t encounter this issue, ever.
You should switch to Reading view before starting your slide(show)
Arrow keys work immediately, no need to click to focus the slide


Yes, toggling to Reading View before starting presentation solved this for me. Thanks!


Thank you! Switching to reading view prior to presentation mode works and allows keyboard control of slides straight away. Still would make sense to me to do the same from edit view.

1 Like

Sorry, I think this is still a bug.

Switching to Reading View is a hack to workaround the problem. Having “Reading View” activated has nothing to do with the keyboard shortcuts, and I think the title of the post shadows the actual issue.

It’s a way to continue working, foremost. Sometimes we just need to adjust because developing applications isn’t trivial and bugfixes have different priorities.

And hack in my opinion, is when you break into other people’s networks and computers. I just added my two cents, or another possible solution.

For now as a more transparent workaround, you can create macro to switch to reading mode and then start presentation, then bind it to a key you use to start presentation instead of the usual command.

To make a macro you can use variety of plugins, I suggest Commander for its simplicity and general usefulness.

If using my shortcut to switch to reading mode and use my other shortcut to start a presentation the keyboard still doesn’t work. I have to click on the botton for reading mode then it works. So for me it is a bug, too.

Update: Can't change slides in slides core plugin mac

Yes this is filed and marked as a bug.