Can't change slides in slides core plugin mac

When I open a note in slides there is no way to change between slides.

The navigation buttons don’t appear and the keyboard arrows and space bar don’t work either.

I’ve separated the slides with ---

I’m using MacOS 10.15.7 and Obsidian version 1.4.12

2 Likes

Moved to help for not following the bug report template.

If you post in help, you see this template. Have you tried these debugging/troubleshooting steps yet?

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

Make sure to redownload Obsidian to get the latest installer. And update any plugins and themes. Test in the Sandbox vault, etc. etc.

And moved back to Bugs because I can reproduce.

It looks like the keyboard focus remains in the note, instead of focusing on the presentation.

If you click on the presentation, then the navigation keys work.

But if you hit space bar, in this screen recording in the Sandbox vault, you can see the spaces get typed into the note, instead of navigating the presentation.

slidesBroken

SYSTEM INFO:
Obsidian version: v1.4.9
Installer version: v1.4.5
Operating system: Darwin Kernel Version 21.6.0: Mon Dec 19 20:43:09 PST 2022; root:xnu-8020.240.18~2/RELEASE_ARM64_T6000 21.6.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

Thanks. I am able to prevent spaces from inserting into the file by clicking on the presentation but this still doesn’t enable me to change slide. Arrow keys not working either. Could I be doing anything else wrong?

No need.

I was typing the ` before and after the —

I had tried just — before but now works with the click on the presentation.

Apologies - I’m new to Obsidian

Thanks!

Don’t mark it as solution; the topic will close automatically. I’ll open it back up. The presentation should receive focus properly. :slight_smile:

I experience same bug with navigation in MacOS 14.2.1 and Obsidian 1.4.13, arrows and space bar don’t work