Cannot update community plugins & themes from Obsidian App

Steps to reproduce

  1. Open Obsidian
  2. Try to update my Community Plugins by clicking “check for updates”
  3. Try to do the same for Appearance & Theme, by clicking on Check for Updates
  4. Nothing happens
  5. Check console (CTRL+SHIFT+I), for errors.
  6. See screenshot.

Did you follow the troubleshooting guide? YES

Expected result

That the Obsidian looks for new plugin and theme updates.

Actual result

Nothing happens


Obsidian version: v1.4.4
Installer version: v1.3.7
Operating system: Windows 10 Home 10.0.22621
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: light
Community theme: AnuPpuccin v1.4.4
Snippets enabled: 10
Restricted mode: off
Plugins installed: 39
Plugins enabled: 31
1: ReadItLater v0.3.1
2: Hotkeys++ v0.2.7
3: Find orphaned files and broken links v1.9.0
4: Focus Mode v1.11.4
5: Paste URL into selection v1.7.0
6: Omnisearch v1.14.2
7: Status Bar Pomodoro Timer v0.1.14
8: QuickShare v1.3.1
9: Emoji Shortcodes v2.2.0
10: Daily Stats v1.0.4
11: Kindle Highlights v1.9.2
12: Templater v1.16.0
13: Media Extended v2.11.1
14: Smart Typography v1.0.18
15: Smart Random Note v0.2.1
16: Vault Statistics v0.1.3
17: Link Exploder v0.3.0
18: Spaced Repetition v1.10.1
19: Contextual Typography v2.2.5
20: Outliner v4.7.1
21: QuickAdd v1.2.1
22: Recent Files v1.3.6
23: Tag Wrangler v0.5.11
24: Style Settings v1.0.6
25: Advanced Tables v0.19.0
26: Workspaces Plus v0.3.3
27: Excalidraw v1.9.8
28: Smart Connections v1.6.34
29: Whisper v1.5.1
30: Zoom v1.1.2
31: Text Generator v0.3.20

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I’ve tried re-installing, adding Obsidian and its folder to WIndows Defender exceptions…and all the other steps you suggest above. It used to work normally for 1 year…now suddenly I can’t update.

Could be a DNS issue?

You could try a different network or change DNS settings to see if it helps.

I think you have a network problem.