Cannot add new text to markdown table when using Live Preview

Steps to reproduce

  1. Enable live preview
  2. Make a new note
  3. Go to edit mode
  4. Use the following code to make a markdown table
| Column 1   | Column 2    | Column 3     |
| ---------- | ----------- | ------------ |
| This       | is          | text         |
| 1          | 2           | 3            |
  1. Wait for the table to render in preview mode
  2. Click on the table, you will see the markdown
  3. Click to the right of the last pipe symbol
  4. Press enter

Expected result

When you press enter, you expect to insert a new line on your markdown so that you can add new text, such a new row to it.

Actual result

When a user presses enter, the markdown table will enter into preview mode. This essentially makes the table UNEDITABLE.

I would expect the table to enter into preview mode only if you click on a line that exists outside of the table markdown.


  • Operating system:
  • Debug info:
    Obsidian version: v0.14.2
    Installer version: v0.12.19
    Operating system: Darwin Kernel Version 20.6.0: Wed Jan 12 22:22:45 PST 2022; root:xnu-7195.141.19~2/RELEASE_ARM64_T8101 20.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 1
    Plugins enabled: 0


Additional information


Ok, I understand your POV. I don’t think that situation is as dramatic as you make it sound. Some user may even prefer the way it works right now.

Please, open a feature request.

1 Like